Bug 461727 - Radeon R430 broken experience (modesetting, X)
Radeon R430 broken experience (modesetting, X)
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 04:55 EDT by Danny Baumann
Modified: 2008-10-08 18:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 18:15:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log including crash backtrace (271.42 KB, text/plain)
2008-09-10 04:55 EDT, Danny Baumann
no flags Details
dmesg output of modesetting oops (47.79 KB, text/plain)
2008-09-10 04:56 EDT, Danny Baumann
no flags Details
dmesg output with kernel from comment #2 (11.68 KB, text/plain)
2008-09-13 09:56 EDT, Danny Baumann
no flags Details
Dmesg output (30.84 KB, text/plain)
2008-10-06 09:59 EDT, Danny Baumann
no flags Details
Xorg log (33.25 KB, text/plain)
2008-10-06 09:59 EDT, Danny Baumann
no flags Details

  None (edit)
Description Danny Baumann 2008-09-10 04:55:42 EDT
Created attachment 316291 [details]
Xorg log including crash backtrace

Description of problem:
- Using kernel modesetting, the kernel oopses (see attached crash_dmesg.txt)
- 2D in X is unusably slow, no matter if compositing is used or not
- Trying to enable compiz leads to an X server crash (see attached Xorg.0.log.old)

Version-Release number of selected component (if applicable):
Rawhide as of 09/10/08

How reproducible:
Always.
Comment 1 Danny Baumann 2008-09-10 04:56:30 EDT
Created attachment 316292 [details]
dmesg output of modesetting oops
Comment 2 Dave Airlie 2008-09-11 02:43:51 EDT
http://koji.fedoraproject.org/scratch/airlied/task_819391/

contains a kernel with a test patch against the nvidia agp driver please see if it lets modesetting start if not attach the dmesg from it please.
Comment 3 Danny Baumann 2008-09-13 09:55:28 EDT
(In reply to comment #2)
> http://koji.fedoraproject.org/scratch/airlied/task_819391/
> 
> contains a kernel with a test patch against the nvidia agp driver please see if
> it lets modesetting start if not attach the dmesg from it please.

Twofold results:
- No kernel oops anymore.
- As soon as the radeon module is initialized, the monitor attached to the DVI port doesn't get any signal anymore.
Comment 4 Danny Baumann 2008-09-13 09:56:59 EDT
Created attachment 316667 [details]
dmesg output with kernel from comment #2
Comment 5 Danny Baumann 2008-09-25 02:03:17 EDT
As of today's Rawhide (kernel 2.6.27-0.352.rc7.git1.fc10.i686, drv-ati 6.9.0-14.fc10.i386)

- X has somewhat reasonable speed
- kernel modesetting makes the screen go blank, but bootup continues

dmesg excerpt:
ATOM BIOS: RADEON X800XL                                                               
[drm] Detected VRAM RAM=262144K, accessible=262144K, BAR=262144K
[drm:drm_agp_bind_ttm] *ERROR* AGP Bind memory failed
[drm:drm_ttm_bind] *ERROR* Couldn't bind backend.
[drm:drm_buffer_object_validate] *ERROR* Failed moving buffer.
[drm:radeon_alloc_gart_objects] *ERROR* failed to allocate ring - most likely an AGP driver bug
Comment 6 Danny Baumann 2008-10-06 09:58:27 EDT
Update for today's rawhide (kernel .391, drv-ati -21):

- Modesetting works fine
- When modesetting is used, X is broken - it shows a random gibberish background with a mouse cursor which can be moved for a short time and then hangs completely)
- VT change is not possible at this point
- X works just fine without kernel modesetting

Will attach current dmesg and Xorg.0.log
Comment 7 Danny Baumann 2008-10-06 09:59:08 EDT
Created attachment 319560 [details]
Dmesg output
Comment 8 Danny Baumann 2008-10-06 09:59:44 EDT
Created attachment 319561 [details]
Xorg log
Comment 9 Matěj Cepl 2008-10-08 18:15:52 EDT

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.