Bug 461744 - samba domain membership breaks after machine account password change
samba domain membership breaks after machine account password change
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Simo Sorce
https://bugzilla.samba.org/show_bug.c...
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 07:57 EDT by Guenther Deschner
Modified: 2014-09-22 07:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:47:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
implement _samr_SetServerPassword2 client (9.79 KB, patch)
2008-09-10 07:59 EDT, Guenther Deschner
no flags Details | Diff

  None (edit)
Description Guenther Deschner 2008-09-10 07:57:47 EDT
Description of problem:

On Samba as a Domain member: After calling "net rpc changetrustpw" the domain trust is broken and it is required to rejoin.


Version-Release number of selected component (if applicable):


How reproducible:

call "net rpc changetrustpw"
and "net rpc testjoin" afterwards


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2008-09-10 07:58:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Guenther Deschner 2008-09-10 07:59:15 EDT
Created attachment 316302 [details]
implement _samr_SetServerPassword2 client

This patch is known to fix the problem for the 3.0 release series.
Comment 3 RHEL Product and Program Management 2008-09-10 08:24:39 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Dmitri Pal 2008-09-10 10:14:57 EDT
Added devel ack.
Comment 10 errata-xmlrpc 2009-01-20 16:47:50 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0180.html

Note You need to log in before you can comment on or make changes to this bug.