Bug 461759 - autopart_type drop-down list labels wrapping
autopart_type drop-down list labels wrapping
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-09-10 09:00 EDT by James Laska
Modified: 2013-09-02 02:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 09:35:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Autopart drop down list (screenshot) (55.03 KB, image/png)
2008-09-10 09:00 EDT, James Laska
no flags Details
Screenshot after applying patch in updates.img (52.40 KB, image/png)
2008-09-10 09:15 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-09-10 09:00:41 EDT
Created attachment 316311 [details]
Autopart drop down list (screenshot)

Description of problem:

On the partitioning screen, the drop-down list text wraps the labels even when space is available.  The only related change appears to have tried to address a similar issue for RHEL5 in commit b10467a573310a25fbe31f79ebbf166fded15042 to address bug#221791.  Should the width's be increased?

Version-Release number of selected component (if applicable):
anaconda-11.4.1.33-1.i386

Actual results:

See screenshot

Expected results:


Additional info:
Comment 1 James Laska 2008-09-10 09:15:40 EDT
Created attachment 316312 [details]
Screenshot after applying patch in updates.img

If I change back the layout width as seen below ...

diff --git a/iw/autopart_type.py b/iw/autopart_type.py
index c1366f7..902497f 100644
--- a/iw/autopart_type.py
+++ b/iw/autopart_type.py
@@ -396,8 +396,8 @@ class PartitionTypeWindow(InstallWindow):
         cell = gtk.CellRendererText()
         self.combo.pack_start(cell, True)
         self.combo.set_attributes(cell, text = 0)
-        cell.set_property("wrap-width", 455)
-        self.combo.set_size_request(480, -1)
+        cell.set_property("wrap-width", 495)
+        self.combo.set_size_request(500, -1)
 
         store = gtk.TreeStore(gobject.TYPE_STRING, gobject.TYPE_INT)
         self.combo.set_model(store)

The drop-down list labels display as one line each.
Comment 2 Chris Lumens 2008-09-10 09:35:01 EDT
Thanks for the patch.  I think this was caused by a commit from the rhel5-branch I brought forward but shouldn't have.

Note You need to log in before you can comment on or make changes to this bug.