Bug 461784 - xend initscript needs to check for existance of /proc/xen/capabilities
xend initscript needs to check for existance of /proc/xen/capabilities
Status: CLOSED DUPLICATE of bug 461658
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 11:35 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 11:44:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2008-09-10 11:35:35 EDT
Description of problem:
I noticed today that with xen-3.0.3-71.el5, we're enabling the xend service by default, but if you are booting up a system with a non-xen kernel, you'll get the following when the xend service attempts to start:

grep: /proc/xen/capabilities: No such file or directory

The initscript should probably check for the existence of the file before attempting to grep through it.

Version-Release number of selected component (if applicable):
3.0.3-71.el5

How reproducible:
Always

Steps to Reproduce:
1. Attempt to start the xend service under a non-xen kernel
Comment 1 Chris Lalancette 2008-09-10 11:44:24 EDT
This is another instance of the problems that are affecting bz 461658, although the symptoms are very different.  Basically, we are now showing a /proc/xen directory on bare-metal where we shouldn't.  This is a kernel bug.  I'll close this as a dup.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 461658 ***

Note You need to log in before you can comment on or make changes to this bug.