Bug 461788 - If Severity is changed on a case SLA times are not updated
If Severity is changed on a case SLA times are not updated
Status: CLOSED CURRENTRELEASE
Product: JBoss Customer Support Portal
Classification: Retired
Component: Gatekeeper (Show other bugs)
1.4
All All
medium Severity medium
: ---
: ---
Assigned To: Nathan Lugert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 11:47 EDT by Frank Merenda
Modified: 2009-02-05 09:21 EST (History)
3 users (show)

See Also:
Fixed In Version: MR8-CSP
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-30 15:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Merenda 2008-09-10 11:47:50 EDT
Problem:

With I-T, it appears that the initial severity selected determines the 
SLA for each response even if the case severity changes.  For example, 
this case [1] had this happen on comments since 7/31/08 @ 4:04pm CDT 
(5:04pm EDT).  The SLA is still 1 business hour instead of 4 business
hours.

[1] https://enterprise.redhat.com/issue-tracker/194163

https://enterprise.redhat.com/issue-tracker/218531
Comment 1 Nathan Lugert 2009-02-05 09:21:09 EST
I-T now calls a CSP Web Service that will update the SLA response time on a case whenever the severity changes. The next time Gatekeeper runs, it will recalculate the SLA Breach time. All SLA Breach calculation times going forward with the case will use the new severity as well.

Note You need to log in before you can comment on or make changes to this bug.