Bug 461823 - anaconda installs the xen kernel based on busted logic
anaconda installs the xen kernel based on busted logic
Status: CLOSED DUPLICATE of bug 461532
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
medium Severity high
: beta
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 16:28 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 09:56:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2008-09-10 16:28:54 EDT
Description of problem:
I don't know how far this goes back, but apparently in support of PV drivers, the latest kernels (even non-xen) present a /proc/xen interface.  There's logic in anaconda which sees this and takes the existence of that interface as proof of running on a guest.  Net result is the -xen kernel gets installed when it shouldn't.

Version-Release number of selected component (if applicable):
11.1.2.120-2

How reproducible:
Always

Steps to Reproduce:
1. Run an install
2.
3.
  
Actual results:


Expected results:


Additional info:
text.py:        if os.path.exists("/proc/xen"): # this keys us that we're a xen guest
yuminstall.py:        if not foundkernel and os.path.exists("/proc/xen"):

Looks like the check in iutil.py was updated already.
Comment 1 Brock Organ 2008-09-10 16:59:31 EDT
Jay, this change is pretty new I think:

* 2.6.18-92.1.10.el5 (from 0905.nightly tree) does not have /proc/xen
* 2.6.18-108.el5     (from 0910.nightly tree) does have /proc/xen

Regards,

Brock
Comment 3 RHEL Product and Program Management 2008-09-11 09:49:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Bill Burns 2008-09-11 09:56:40 EDT
This is due to /proc/xen being present in bare metal due to XenPV drivers. It is being fixed via 461532.

*** This bug has been marked as a duplicate of bug 461532 ***

Note You need to log in before you can comment on or make changes to this bug.