Bug 461840 - iscsi node.start attribute not set to automatic
iscsi node.start attribute not set to automatic
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 17:21 EDT by Hans de Goede
Modified: 2008-10-07 18:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 18:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-09-10 17:21:14 EDT
Using boot.iso and install.img dated 2008-09-10, and trying to put /home on an iscsi disk, /home would not get mounted as the configfile under /var/lib/iscsi/nodes for the used iscsi "node" had the node.start attribute set to "manual" changing this to "automatic" fixes this.
Comment 1 Hans de Goede 2008-09-22 09:19:56 EDT
Interesting enough the opposite has just been done in RHEL-5, their things have been changed to not set the startup to automatic, see bug 437891.

What is happening here is that with / on iscsi we do not want to try and start the node(s) corresponding to the raid / logvol / partition used to autostart because they are already started and the node database may even contain wrong info causing problems as described in bug 437891. However for /somedir on iscsi we do want to set the node to autostart, as there the node will not have been started from the initrd, so without starting it we won't have a connection to the disk for /somedir.

I have discussed this with pjones and the plan is to write a patch which sets node.startup to automatic for non / containing iscsi nodes. This patch will at first only go to Fedora.
Comment 2 Hans de Goede 2008-10-07 18:34:13 EDT
A patch which sets node.startup to automatic for non / containing iscsi nodes has just been pushed to git, closing.

Note You need to log in before you can comment on or make changes to this bug.