Bug 461880 - firefox-2.0-getstartpage.patch breaks extensions which set homepage
firefox-2.0-getstartpage.patch breaks extensions which set homepage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 02:42 EDT by Traxtopel
Modified: 2008-11-14 03:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 03:18:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Traxtopel 2008-09-11 02:42:55 EDT
+++ This bug was initially created as a clone of Bug #454283 +++

Description of problem:
firefox-2.0-getstartpage.patch removes the code that allows
browser.startup.homepage to come from a properties file of a 3rd party extension.

Version-Release number of selected component (if applicable):
firefox-3.0 2.el5

--- Additional comment from pm-rhel@redhat.com on 2008-07-08 18:29:07 EDT ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

--- Additional comment from traxtopel@fastmail.fm on 2008-07-09 08:46:11 EDT ---

Should I also open a bug report for Fedora 9, since the same patch is included
in their build, or will this be fix be reflected there also?

--- Additional comment from walicki@us.ibm.com on 2008-08-13 16:18:19 EDT ---

This firefox-2.0-getstartpage.patch is causing problems with the internal Firefox 3 deployment within IBM.   IBM uses the Mozilla CCK (Client Customization Kit) to customize Firefox for internal IBMers.  We set the homepage to our Intranet URL and set a variety of other parameters.  The CCK is a important feature for IBM.

The firefox-2.0-getstartpage.patch removes the code that allows
browser.startup.homepage to come from a properties file of a 3rd party extension (which is EXACTLY what the CCK does!)

IBM requests that Red Hat Enterprise Linux (and Fedora) back out this custom patch and deliver Firefox as intended so that our enterprise deployment can proceed.  We've used this feature since Firefox 1.0 and are disappointed that its been disabled.

--- Additional comment from mcepl@redhat.com on 2008-08-28 08:09:15 EDT ---

(In reply to comment #2)
> Should I also open a bug report for Fedora 9, since the same patch is included
> in their build, or will this be fix be reflected there also?

Yes, please.
Comment 1 John Walicki 2008-10-29 13:28:38 EDT
IBM is still waiting for the Fedora/RHEL builds of the Firefox 3.0.3 security release.  I understand Firefox 3.0.3 will back out this patch and allow us to clear this deployment blocker for internal IBM.

Note You need to log in before you can comment on or make changes to this bug.