Bug 461899 - Review Request: thebridge - ILink/EchoLink compatible conference bridge
Review Request: thebridge - ILink/EchoLink compatible conference bridge
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
: 463590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 05:50 EDT by Lucian Langa
Modified: 2008-12-30 18:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-07 10:55:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tibbs: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Lucian Langa 2008-09-11 05:50:12 EDT
Spec URL: http://lucilanga.fedorapeople.org/thebridge.spec
SRPM URL: http://lucilanga.fedorapeople.org/thebridge-0.96-1.fc9.src.rpm
Description: Thebridge is an EchoLink compatible conference bridge that runs under
FreeBSD, Linux, QNX, Mac OS X, Windows and hopefully most other Posix
compatible operating systems.
Comment 1 Lucian Langa 2008-09-24 02:50:07 EDT
*** Bug 463590 has been marked as a duplicate of this bug. ***
Comment 2 Jason Tibbitts 2008-11-20 16:17:10 EST
This package includes its own, old, copy of zlib, and it seems to build and link against it statically.  It really needs to build against the system zlib instead.

I'm not sure there's much point in stating that this softwarew runs inder QNX or OS X, as this package certainly won't.

I note that 1.06 seems to be the current version.  Any reason not to update to it?  (I don't know if it has the zlib problem or not.)
Comment 3 Lucian Langa 2008-11-21 12:40:11 EST
(In reply to comment #2)
> This package includes its own, old, copy of zlib, and it seems to build and
> link against it statically.  It really needs to build against the system zlib
> instead.
Fixed.


> I'm not sure there's much point in stating that this softwarew runs inder QNX
> or OS X, as this package certainly won't.
Updated.

> I note that 1.06 seems to be the current version.  Any reason not to update to
> it?  (I don't know if it has the zlib problem or not.)
Updated. (same zlib issue).

new version:
http://lucilanga.fedorapeople.org/thebridge.spec
http://lucilanga.fedorapeople.org/thebridge-1.06-2.fc10.src.rpm
Comment 4 Jason Tibbitts 2008-12-02 21:19:16 EST
I cannot seem to fetch Source0; I think you need http://downloads.sourceforge.net/cqinet/%{name}-%{version}.tgz. 

You are missing the dependencies for the calls you make in the scriptlets:

Requires(post): chkconfig
Requires(preun): chkconfig
Requires(preun): initscripts
Requires(postun): initscripts

* source files match upstream.  sha256sum:
   401646f336b052555abc776e40e94b3990b7c198f2a9ec65bf45ee45acbab6a2  
   thebridge-1.06.tgz
  (after fixing Source0: URL so that it downloads)
* package meets naming and versioning guidelines.
* specfile is properly named, is cleanly written and uses macros consistently.
* summary is OK.
* description is OK.
* dist tag is present.
* build root is OK.
* license field matches the actual license.
* license is open source-compatible.
* license text included in package.
* latest version is being packaged.
* BuildRequires are proper.
* compiler flags are appropriate.
* %clean is present.
* package builds in mock (rawhide, x86_64).
* package installs properly.
* debuginfo package looks complete.
* rpmlint is silent.
X final provides and requires:
   config(thebridge) = 1.06-2.fc11
   thebridge = 1.06-2.fc11
   thebridge(x86-64) = 1.06-2.fc11
  =
   /bin/bash
   /bin/sh
   config(thebridge) = 1.06-2.fc11
   libz.so.1()(64bit)
  Missing scriptlet dependencies.

* no shared libraries are added to the regular linker search paths.
* owns the directories it creates.
* doesn't own any directories it shouldn't.
* no duplicates in %files.
* file permissions are appropriate.
* no generically named files
* scriptlets OK (service management).
* code, not content.
* documentation is small, so no -doc subpackage is necessary.
* %docs are not necessary for the proper functioning of the package.
* no headers.
* no pkgconfig files.
* no static libraries.
* no libtool .la files.
Comment 5 Lucian Langa 2008-12-03 00:50:53 EST
(In reply to comment #4)
> http://downloads.sourceforge.net/cqinet/%{name}-%{version}.tgz. 

> You are missing the dependencies for the calls you make in the scriptlets:

Updated:

http://lucilanga.fedorapeople.org/thebridge.spec
http://lucilanga.fedorapeople.org/thebridge-1.06-3.fc10.src.rpm

Thank you.
Comment 6 Jason Tibbitts 2008-12-06 00:31:42 EST
Source URL and the dependencies are fixed; everything looks fine.

APPROVED
Comment 7 Lucian Langa 2008-12-06 03:44:05 EST
New Package CVS Request
=======================
Package Name: thebridge
Short Description: ILink/EchoLink compatible conference bridge
Owners: lucilanga
Branches: F-9 F-10 EL-5
InitialCC:
Comment 8 Kevin Fenzi 2008-12-06 22:31:36 EST
cvs done.
Comment 9 Fedora Update System 2008-12-07 10:52:05 EST
thebridge-1.06-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/thebridge-1.06-3.fc9
Comment 10 Fedora Update System 2008-12-07 10:53:14 EST
thebridge-1.06-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/thebridge-1.06-3.fc10
Comment 11 Fedora Update System 2008-12-30 18:43:33 EST
thebridge-1.06-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-12-30 18:53:21 EST
thebridge-1.06-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.