Bug 461911 - Yum fails to work after update.
Yum fails to work after update.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 07:52 EDT by Ryan Mauger
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 08:24:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yum log (25.62 KB, text/plain)
2008-09-11 07:52 EDT, Ryan Mauger
no flags Details

  None (edit)
Description Ryan Mauger 2008-09-11 07:52:39 EDT
Created attachment 316428 [details]
Yum log

Description of problem:
Yum fails completly after update

Version-Release number of selected component (if applicable):


How reproducible:
Unknown

Additional info:
Ruinning yum now produces the following output no matter what options are provided. This error happened immediatly after fedoa system update updated a whole bunch of stuff (see attached yum.log)

The version of python on this system is
Python 2.5.1 (r251:54863, Jul 10 2008, 17:24:48) 

Loaded plugins: fastestmirror, skip-broken
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 84, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig
    enabled_plugins=self.optparser._splitArg(opts.enableplugins))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 189, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 355, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 160, in __init__
    self.run('config')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 176, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/skip-broken.py", line 110, in config_hook
    help="skip packages with broken dependencies")    
  File "/usr/lib/python2.5/optparse.py", line 1014, in add_option
    self._check_conflict(option)
  File "/usr/lib/python2.5/optparse.py", line 989, in _check_conflict
    option)
optparse.OptionConflictError: option --skip-broken: conflicting option string(s): --skip-broken
Comment 1 Ryan Mauger 2008-09-11 08:05:31 EDT
Resolved this problem by removing yum-skip-broken.
Comment 2 seth vidal 2008-09-11 08:24:56 EDT
I'm going to close this as not a bug but we have made a change to the spec file so that this plugin cannot be installed with a version of yum that includes the skip-broken functionality.

thanks

Note You need to log in before you can comment on or make changes to this bug.