Bug 461923 - AttributeError: 'module' object has no attribute 'HTTPSHandler'
AttributeError: 'module' object has no attribute 'HTTPSHandler'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
medium Severity medium
: beta
: ---
Assigned To: Chris Lumens
http://rhts.redhat.com/cgi-bin/rhts/t...
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 09:30 EDT by Jeff Burke
Modified: 2009-02-10 06:33 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:35:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-09-11 09:30:40 EDT
Description of problem:
* RHEL5.3-Server-20080911.nightly x86_64
* Error appears through automate RHTS testing
* Behavior appears arch independent

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20080911.nightly

How reproducible:
Always

Steps to Reproduce:
1. Try a nfs install from pxe with a ks.cfg file
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 618, in ?
    instClass = getInstClass(opts)
  File "/usr/bin/anaconda", line 356, in getInstClass
    from kickstart import Kickstart
  File "/usr/lib/anaconda/kickstart.py", line 27, in ?
    import urlgrabber.grabber as grabber
  File "/usr/lib/python2.4/site-packages/urlgrabber/__init__.py", line 53, in ?
    from grabber import urlgrab, urlopen, urlread
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 412, in ?
    import keepalive
  File "/usr/lib/python2.4/site-packages/urlgrabber/keepalive.py", line 339, in ?
    class HTTPSHandler(KeepAliveHandler, urllib2.HTTPSHandler):
AttributeError: 'module' object has no attribute 'HTTPSHandler'
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0
	/proc/bus/usb done
	/proc done
	/dev/pts done
	/sys done
	/tmp/ramfs done
	/mnt/source done
	/selinux done
you may safely reboot your system

Expected results:
Install should work

Additional info:
Comment 2 Chris Lumens 2008-09-11 10:10:43 EDT
Looks like this is a problem in urllib2, which is a part of python.
Comment 3 Jeremy Katz 2008-09-11 10:29:09 EDT
Not urllib, missing libs in stage2.  HTTPSConnection only exists if the ssl module can be imported.  Loopback mounting the stage2...
>>> import _ssl
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
ImportError: libfipscheck.so.1: cannot open shared object file: No such file or directory
Comment 5 Chris Lumens 2008-09-11 16:29:15 EDT
This should be fixed in anaconda-11.1.2.122-1.
Comment 10 Sergey Kurtsev 2009-01-16 13:54:01 EST
The same error is generated by yum after the recent update. And it makes it impossible to receive new updates without hacking 'keepalive.py'

Name       : python
Arch       : i386
Version    : 2.6
Release    : 2.fc11

Error log:

[root@digger !photo]# yum -y update
Traceback (most recent call last):
  File "/usr/bin/yum", line 4, in <module>
    import yum
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 49, in <module>
    import config
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 27, in <module>
    from parser import ConfigPreProcessor
  File "/usr/lib/python2.6/site-packages/yum/parser.py", line 3, in <module>
    import urlgrabber
  File "/usr/lib/python2.6/site-packages/urlgrabber/__init__.py", line 53, in <module>
    from grabber import urlgrab, urlopen, urlread
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 410, in <module>
    import keepalive
  File "/usr/lib/python2.6/site-packages/urlgrabber/keepalive.py", line 444, in <module>
    class HTTPSConnection(httplib.HTTPSConnection):
AttributeError: 'module' object has no attribute 'HTTPSConnection'
Comment 11 Chris Lumens 2009-01-16 16:23:08 EST
Sergey - while you're seeing the same end result, your bug is not at all the same as this RHEL 5.3 bug report.  You're seeing the product of the recent openssl troubles in Rawhide, and you'll need to wait until Fedora sorts that out before being able to resume normal package updating.
Comment 12 errata-xmlrpc 2009-01-20 16:35:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html
Comment 13 Levente Farkas 2009-02-10 06:33:30 EST
it's still not working!
should i have to open a new bug report or someone can reopen this bug?
i test it with rhel-5.3 and got this result (just 2 lines shift in anaconda code!):
---------------------------------------------------
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 620, in ?
    instClass = getInstClass(opts)
  File "/usr/bin/anaconda", line 358, in getInstClass
    from kickstart import Kickstart
  File "/usr/lib/anaconda/kickstart.py", line 27, in ?
    import urlgrabber.grabber as grabber
  File "/usr/lib/python2.4/site-packages/urlgrabber/__init__.py", line 53, in ?
    from grabber import urlgrab, urlopen, urlread
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 412, in ?
    import keepalive
  File "/usr/lib/python2.4/site-packages/urlgrabber/keepalive.py", line 339, in
?
    class HTTPSHandler(KeepAliveHandler, urllib2.HTTPSHandler):
AttributeError: 'module' object has no attribute 'HTTPSHandler'
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
 /mnt/runtime done
 disabling /dev/loop0
 /proc/bus/usb done
 /proc done
 /dev/pts done
 /sys done
 /tmp/ramfs done
 /mnt/source done
 /selinux done
you may safely reboot your system
---------------------------------------------------
imho it's still a bug and should have to fix asap.
i'd be happy even if anyone can send me patch.
thanks in advance.
yours.

Note You need to log in before you can comment on or make changes to this bug.