Bug 461925 - RuntimeError: Couldn't create storage volume 'virt-stor-dir-bochs.img': '/usr/bin/qemu-img exited with non-zero status 1 and signal 0'
RuntimeError: Couldn't create storage volume 'virt-stor-dir-bochs.img': '/usr...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 461931 461930
  Show dependency treegraph
 
Reported: 2008-09-11 09:54 EDT by James Laska
Modified: 2013-09-02 02:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-07 15:36:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot (157.50 KB, image/png)
2008-09-11 09:54 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-09-11 09:54:03 EDT
Created attachment 316444 [details]
Screenshot

Description of problem:

Error occured while creating a bochs storage volume in a directory storage pool.


Version-Release number of selected component (if applicable):

libvirt-0.4.5-2.fc10.i386
virt-manager-0.6.0-1.fc10.i386
qemu-0.9.1-10.fc10.i386


How reproducible:
100%

Steps to Reproduce:
1. Create a 'dir' storage pool
2. Create a 'bochs' storage volume of max/alloc == 2000/2000
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/createvol.py", line 191, in _async_vol_create
    poolobj = self.vol.install(meter=meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Storage.py", line 893, in install
    (self.name, str(e)))
RuntimeError: Couldn't create storage volume 'virt-stor-dir-bochs.img': '/usr/bin/qemu-img exited with non-zero status 1 and signal 0'


Expected results:
no traceback

Additional info:

* See attached screenshot. 
* Please advise if additional information/logfiles are needed.
Comment 1 Bug Zapper 2008-11-25 22:02:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Cole Robinson 2008-12-07 15:36:03 EST
Since this isn't really a 'bug', but more expected-behaviour-communicated-poorly-to-the-user, I'm closing as NOTABUG.

The issues here are that libvirt gives a useless error message (now fixed as of version 0.5.0) and that there is no indication from libvirt which storage formats support which operations (bug 461931)

Note You need to log in before you can comment on or make changes to this bug.