Bug 461935 - HTS creates unnecessary intermediate files config.xml, plan.xml
HTS creates unnecessary intermediate files config.xml, plan.xml
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 10:52 EDT by Greg Nichols
Modified: 2014-03-25 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:57:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hardwaretest.py patch to remove config.xml and plan.xml (6.21 KB, patch)
2008-09-11 10:55 EDT, Greg Nichols
no flags Details | Diff
hardwaretest.py patch to remove config.xml and plan.xml (6.86 KB, patch)
2008-09-11 10:58 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2008-09-11 10:52:04 EDT
Description of problem:

HTS creates unncessary intermediate files, config.xml and plan.xml.
The contents of these files is copied into the results.xml.  HTS
should be changed to use a single xml file for managing test 
plans and results.

Also, the "hts config" command is superflous, and should be removed,
since "hts plan" will determine configuration information.
Comment 1 Greg Nichols 2008-09-11 10:55:05 EDT
Created attachment 316448 [details]
hardwaretest.py patch to remove config.xml and plan.xml


This patch removes the config.xml and plan.xml files, changing HTS to manage this data only in results.xml, eliminating the redundant files.

This patch also removes the "hts config" command.
Comment 2 Greg Nichols 2008-09-11 10:58:30 EDT
Created attachment 316449 [details]
hardwaretest.py patch to remove config.xml and plan.xml


Patch updated to remove the "hts discover" command from the help text.
Comment 4 Yan Tian 2009-01-01 21:24:28 EST
Verified following in hts-5.3-12:
- "hts plan" only create /var/hts/results.xml file, not found config.xml and plan.xml under /var/hts
- both "hts config" and "hts discover" commands were removed.
Comment 6 errata-xmlrpc 2009-01-27 17:57:52 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.