Bug 461951 - pidgin with proxy crashes - segfault
Summary: pidgin with proxy crashes - segfault
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin
Version: 8
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-09-11 16:21 UTC by oscar cassetti
Modified: 2008-10-20 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-16 02:09:05 UTC
Type: ---


Attachments (Terms of Use)
Backtrace from running pidgin in GDB (6.60 KB, text/plain)
2008-10-06 21:00 UTC, William Lovaton
no flags Details

Description oscar cassetti 2008-09-11 16:21:05 UTC
Description of problem:
Pidgin does a SEGFAUL when using proxy and "GNOME-proxy Settings"

Version-Release number of selected component (if applicable):
2.5.1

How reproducible:
Always when you have a proxy

Steps to Reproduce:
1. Set an http proxy in gnome-network-properties and select use this proxy for
every protocol
2.Set an account in pidgin to use the GNOME proxy Settings
3. try to connect 
  
Actual results:
segmentation fault

Expected results:


Additional info:
I reported a possible solution at 
http://developer.pidgin.im/ticket/7051

Comment 1 Fedora Update System 2008-09-16 15:34:29 UTC
pidgin-2.5.1-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/pidgin-2.5.1-3.fc9

Comment 2 Fedora Update System 2008-09-16 15:34:32 UTC
pidgin-2.5.1-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/pidgin-2.5.1-3.fc8

Comment 3 Fedora Update System 2008-09-25 00:05:53 UTC
pidgin-2.5.1-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pidgin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8214

Comment 4 Fedora Update System 2008-09-25 00:10:53 UTC
pidgin-2.5.1-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pidgin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8243

Comment 5 William Lovaton 2008-10-06 20:44:39 UTC
I'm here just to say "me too".  I'll apply the new pidgin from updates-testing and report back.

Comment 6 William Lovaton 2008-10-06 21:00:47 UTC
Created attachment 319598 [details]
Backtrace from running pidgin in GDB

Maybe it doesn't help because I don't have the debugging symbols but here is a backtrace.

I can't test the new version because yum doesn't seen anything new in the updates-testing repository (pidgin-2.5.1-3.fc8).  The version I have installed is pidgin-2.5.1-1.fc8.  I then tried "yum clean all" and disabling the fastestmirror plugin but yum keeps saying that "No Packages marked for Update".  The command I used is this one:
yum --disableplugin=fastestmirror --enablerepo=updates-testing update pidgin

What can I do?? do I need a new signing key for updates-testing??

Comment 7 Stu Tomlinson 2008-10-06 21:18:08 UTC
It's actually in the "updates-testing-newkey" repo, which is in use after issuing new signing keys earlier:

su -c 'yum --enablerepo=updates-testing-newkey update pidgin'

Comment 8 William Lovaton 2008-10-06 21:36:13 UTC
Duh, I just realized that I had to use the -newkey repository.

I just installed the updates and initial testing shows that the bug seems to be corrected.  I'll give it a try for a couple of days and report back.

Thanks.

Comment 9 Fedora Update System 2008-10-16 02:09:02 UTC
pidgin-2.5.1-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-10-20 22:07:52 UTC
pidgin-2.5.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.