Bug 461954 - File descriptor leak in event processing
File descriptor leak in event processing
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: ZStream
: 461943 (view as bug list)
Depends On:
Blocks: 495528
  Show dependency treegraph
 
Reported: 2008-09-11 12:45 EDT by Lon Hohberger
Modified: 2010-10-23 00:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:12:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes file descriptor leak. (2.13 KB, patch)
2008-09-11 12:45 EDT, Lon Hohberger
no flags Details | Diff
Correct patch. (1.47 KB, application/octet-stream)
2008-09-11 12:46 EDT, Lon Hohberger
no flags Details

  None (edit)
Description Lon Hohberger 2008-09-11 12:45:05 EDT
Created attachment 316456 [details]
Fixes file descriptor leak.

Description of problem:

When various cluster events occur (and are not user-generated), rgmanager can occasionally leak a file descriptor.

Version-Release number of selected component (if applicable): 1.9.80
Comment 1 Lon Hohberger 2008-09-11 12:46:22 EDT
Created attachment 316458 [details]
Correct patch.

Previous was wrong patch; this is the correct one.
Comment 2 Lon Hohberger 2008-09-11 12:47:40 EDT
Pushed to RHEL4 branch.
Comment 7 errata-xmlrpc 2009-05-18 17:12:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1048.html
Comment 10 Lon Hohberger 2010-01-27 13:17:40 EST
*** Bug 461943 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.