Bug 461962 - virt-manager should support logical pool enumeration
virt-manager should support logical pool enumeration
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2008-09-11 13:27 EDT by James Laska
Modified: 2013-09-02 02:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 18:52:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screencast.ogg (756.85 KB, application/octet-stream)
2008-09-11 13:27 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-09-11 13:27:37 EDT
Created attachment 316463 [details]
Screencast.ogg

Description of problem:

Attempting to add an LVM VolGroup is not clear.  It appears like the dialog is not allowing me to enter a the volume group.  Perhaps tooltips or documentation might be in order.

Version-Release number of selected component (if applicable):

libvirt-0.4.5-2.fc10.i386
virt-manager-0.6.0-1.fc10.i386
qemu-0.9.1-10.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1. start virt-manager
2. Select 'Details' for QEMU localhost
3. Select 'Storage Pools' tab
4. Select 'Add'
5. Select type=logical, name=VolGroup00, select Next
6. Select Next

Actual results:
See http://jlaska.fedorapeople.org/lvm-stor.png

Clicking next yields ...

[Wed, 24 Sep 2008 15:37:26 virt-manager 22506] DEBUG (Storage:370) Creating storage pool 'VolGroup00' with xml:
<pool type='logical'>
  <name>VolGroup00</name>
  <uuid>372d8c11-e3ae-af96-7d8c-fb0f0abb86c0</uuid>
  <target>
    <path>/dev/VolGroup00</path>
  </target>
</pool>
[Wed, 24 Sep 2008 15:37:26 virt-manager 22506] ERROR (createpool:297) Error creating pool: Could not define storage pool: cannot extract storage pool source devices
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/createpool.py", line 291, in _async_pool_create
    poolobj = self._pool.install(create=True, meter=meter, build=build)
  File "/usr/lib/python2.5/site-packages/virtinst/Storage.py", line 375, in install
    raise RuntimeError(_("Could not define storage pool: %s" % str(e)))
RuntimeError: Could not define storage pool: cannot extract storage pool source devices


Expected results:
 * it doesn't appear possible to enter a LVM Volume Group name for use with the storage pool

Additional info:
Comment 1 Bug Zapper 2008-11-25 22:02:46 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Daniel Berrange 2009-01-22 08:15:42 EST
Re-assigning to virt-manager for now, because from my testing, the libvirt side of things is working OK.
Comment 3 Cole Robinson 2009-04-06 14:06:13 EDT
If I understand correctly, the root of this issue is that the storage pool 'name' for an LVM pool is used as the source VG name, if no source name is specified (if creating a pool from an existing VG). This is confusing, since for all other storage pool types, 'name' is strictly metadata.

We should really be using the logical pool discovery functionality to provide a list of volume groups to the user: we can use this info to specify the 'source' device name. Granted, it would be nice if libvirt did this behind the scenes if no source name is specified, but we need to implement this functionality in virt-manager regardless.
Comment 4 Cole Robinson 2009-09-14 11:55:56 EDT
This likely won't be fixed for F10, moving to F11.
Comment 5 Cole Robinson 2009-10-21 10:17:37 EDT
We now support pool enumeration upstream:

http://hg.fedorahosted.org/hg/virt-manager/rev/d46b95ddbbcf

This requires changes across virtinst and virt-manager, so I don't think this will be backported to F11. Moving to rawhide/F12
Comment 6 Cole Robinson 2009-12-03 18:52:49 EST
This should be fixed in virt-manager-0.8.1-1.fc13 which will be in the next rawhide compose.

Note You need to log in before you can comment on or make changes to this bug.