Bug 461976 - (perl-Gtk2-ImageView) Review Request: perl-Gtk2-ImageView - Perl bindings to the GtkImageView image viewer widget
Review Request: perl-Gtk2-ImageView - Perl bindings to the GtkImageView image...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 453772 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 13:52 EDT by Tom "spot" Callaway
Modified: 2013-01-09 23:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 10:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jkeating: fedora‑review+
tcallawa: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2008-09-11 13:52:02 EDT
Spec URL: http://www.auroralinux.org/people/spot/review/new/perl-Gtk2-ImageView.spec
SRPM URL: http://www.auroralinux.org/people/spot/review/new/perl-Gtk2-ImageView-0.04-1.fc10.src.rpm
Description: 
Perl bindings to the GtkImageView image viewer widget. Find out more about
GtkImageView at http://trac.bjourne.webfactional.com/. The Perl bindings follow
the C API very closely, and the C reference should be considered the canonical
documentation.


Note: You'll need this updated perl-Glib package to build/use this:
http://koji.fedoraproject.org/koji/taskinfo?taskID=820825

Accordingly, this is a rawhide only item (F10+).
Comment 1 Mamoru TASAKA 2008-09-11 14:10:50 EDT
Currently I am waiting for a reply from the submitter on bug 453772 .
Comment 2 Tom "spot" Callaway 2008-09-11 14:22:18 EDT
I didn't see that one, apologies. Jesse Keating pointed out that we had broken dependencies in rawhide, so I whipped up a package to fix it.
Comment 3 Jesse Keating 2008-09-11 17:33:59 EDT
I tried installing all the BuildRequires, including the listed koji build, but when I tried to build the srpm I got:

+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor 'OPTIMIZE=-O2 -g'
Can't locate Gtk2.pm in @INC (@INC contains: /usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/local/lib/perl5/site_perl /usr/local/lib64/perl5/site_perl .) at (eval 9) line 1.
BEGIN failed--compilation aborted at (eval 9) line 1.

Checking if your kit is complete...
Looks good
MakeMaker FATAL: prerequisites not found.
    Gtk2 not installed

Please install these modules first and rerun 'perl Makefile.PL'.
error: Bad exit status from /var/tmp/rpm-tmp.cA3OLn (%build)


Looks like a missing BuildRequire on perl-Gtk2 (or the proper perl module therein)

Other than that, it builds, passes rpmlint, and the spec looks fine regarding both packaging guidelines and the specific perl guidelines.

Correct the missing BuildRequires and this is approved.
Comment 4 Tom "spot" Callaway 2008-09-12 10:15:55 EDT
New Package CVS Request
=======================
Package Name: perl-Gtk2-ImageView
Short Description: Perl bindings to the GtkImageView image viewer widget
Owners: spot
Branches: F-8 F-9 devel
InitialCC: perl-sig

... and it's done.
Comment 5 Tom "spot" Callaway 2008-09-12 10:31:06 EDT
Built in rawhide.
Comment 6 Mamoru TASAKA 2008-09-12 10:43:00 EDT
*** Bug 453772 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.