Bug 462005 - resgen2 fails to compile resx file without a working X display
resgen2 fails to compile resx file without a working X display
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 16:50 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2008-09-17 11:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 11:20:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Novell 425647 None None None Never

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2008-09-11 16:50:51 EDT
Description of problem:
resgen2 fails to compile resx file if $DISPLAY is unset or if it is set to a
non-existent DISPLAY.

Version-Release number of selected component (if applicable):
mono-core-2.0-6.fc10
mono-winforms-2.0-6.fc10

How reproducible:
Always.

Steps to Reproduce:
1. Download cs_obexftp sources from http://cs-obexftp.svn.sourceforge.net/viewvc/cs-obexftp/trunk/Cs-ObexFtp/Cs-ObexFtp.tar.gz
2. unset DISPLAY
3. ./configure && make
  
Actual results:
make[1]: Entering directory `/builddir/build/SOURCES/Cs-ObexFtp/Cs-ObexFtp'
resgen2 -usesourcepath 'Forms/About.de.resx' 'Forms/About.de.resources'
Read in 13 resources from '/builddir/build/SOURCES/Cs-ObexFtp/Cs-ObexFtp/Forms/About.de.resx'
Writing resource file...  Done.
resgen2 -usesourcepath 'Forms/About.fr.resx' 'Forms/About.fr.resources'
Read in 9 resources from '/builddir/build/SOURCES/Cs-ObexFtp/Cs-ObexFtp/Forms/About.fr.resx'
Writing resource file...  Done.
resgen2 -usesourcepath 'Forms/About.it.resx' 'Forms/About.it.resources'
Read in 15 resources from '/builddir/build/SOURCES/Cs-ObexFtp/Cs-ObexFtp/Forms/About.it.resx'
Writing resource file...  Done.
resgen2 -usesourcepath 'Forms/About.resx' 'Forms/About.resources'
Error: Invalid ResX input.
Inner exception: An exception was thrown by the type initializer for System.Windows.Forms.TableLayoutPanel  Line 230, position 5.
make[1]: *** [Forms/About.resources] Error 1
make[1]: Leaving directory `/builddir/build/SOURCES/Cs-ObexFtp/Cs-ObexFtp'
make: *** [all-recursive] Error 1

Expected results:
make[1]: Entering directory `/builddir/build/SOURCES/Cs-ObexFtp/Cs-ObexFtp'
resgen2 -usesourcepath 'Forms/About.resx' 'Forms/About.resources'
Read in 129 resources from '/builddir/build/SOURCES/Cs-ObexFtp/Cs-ObexFtp/Forms/About.resx'
Writing resource file...  Done.
...
Comment 1 Paul F. Johnson 2008-09-11 17:18:51 EDT
What architecture are you using?
Comment 2 Dominik 'Rathann' Mierzejewski 2008-09-11 17:28:55 EDT
fedora-devel-i386 mock chroot on F-8/x86_64

I'm pretty sure it isn't arch-dependent.
Comment 3 Paul F. Johnson 2008-09-11 17:30:42 EDT
By the looks of it, resgen2 is compiling the resources files fine from other parts of the application. Are you sure that this is a resgen2 error and not the package (I'm not saying it is the package...)

What are you doing with F8 on your box? ;-) Surely if you're using fedora-devel, you're on rawhide == f10?
Comment 4 Dominik 'Rathann' Mierzejewski 2008-09-11 17:57:04 EDT
(In reply to comment #3)
> By the looks of it, resgen2 is compiling the resources files fine from other
> parts of the application. Are you sure that this is a resgen2 error and not the
> package (I'm not saying it is the package...)

Well, the author says that it compiles for him just fine and indeed, if only I have DISPLAY set to :0.0, it compiles just fine for me, too.

> What are you doing with F8 on your box? ;-) Surely if you're using
> fedora-devel, you're on rawhide == f10?

I'm too lazy to upgrade. ;) Besides, mock is enough for testing.
Comment 5 Paul F. Johnson 2008-09-11 18:32:27 EDT
As reported on the Novell BZ, to compile a SWF resources file you need a correctly configured DISPLAY variable.

Closing this bug...
Comment 6 Dominik 'Rathann' Mierzejewski 2008-09-11 18:43:15 EDT
Looks like a bad joke. As I mentioned there, this is going to keep biting anyone who packages software written in C# which uses that construct. I've always thought Mono was a bad idea. This proves my point.
Comment 7 Dominik 'Rathann' Mierzejewski 2008-09-12 09:46:21 EDT
It's been reopened upstream, so reopening here as well.
Comment 8 Dominik 'Rathann' Mierzejewski 2008-09-17 10:47:17 EDT
Fixed upstream, please backport the patch. It's been reported working on the openobex-users list by cs-obexftp author.
Comment 9 Paul F. Johnson 2008-09-17 11:20:26 EDT
Fixed - should be in tomorrows (Thurs) rawhide push - assuming we have one...

Note You need to log in before you can comment on or make changes to this bug.