Bug 462055 - [fix available] RTF format export encoding problem
[fix available] RTF format export encoding problem
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 04:45 EDT by Vivian Bian
Modified: 2009-09-02 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:08:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the odt file,saved by the oowriter (ja_JP) 2.3.0-6.8.el5.x86_64 (6.44 KB, text/plain)
2008-09-12 05:22 EDT, Vivian Bian
no flags Details
This is the rtf file saved by the same version of the ODTfile (2.27 KB, text/plain)
2008-09-12 05:23 EDT, Vivian Bian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 93949 None None None Never

  None (edit)
Description Vivian Bian 2008-09-12 04:45:15 EDT
Description of problem:
I typed some English words in the writer,and saved it as the rtf format and closed it.Then double click the rtf file , having found the wrong words there.

Version-Release number of selected component (if applicable):
RHEL5 Client x86_64 (ja_JP)
openoffice.org-2.3.0-6.8.el5 (ja_JP)

How reproducible:

sometimes,we type the special English words
Steps to Reproduce:
1.start up the oowriter via typing the LANG=ja_JP.UTF-8 oowriter in the terminal
2.Type some English words in ,such as I don't know.
3.save the file as the .rtf format.Close the file.

open  the .rtf file saved just now. And the ‘稚’will be found in the location of the "  't  " of the sentence "I don't know".
  
Actual results:
There are some wrong words in the rtf file when we type the special words.

Expected results:
There is no wrong word in the rtf file.

Additional info:
Comment 1 Caolan McNamara 2008-09-12 04:52:07 EDT
Could you write a simple document, then save it as .odt, load it back up and save it again as .rtf and confirm that the problem is reproducible that way, and then attach your .odt input document and .rtf output document to this issue.
Comment 2 Vivian Bian 2008-09-12 05:22:48 EDT
Created attachment 316554 [details]
This is the odt file,saved by the oowriter (ja_JP) 2.3.0-6.8.el5.x86_64
Comment 3 Vivian Bian 2008-09-12 05:23:51 EDT
Created attachment 316555 [details]
This is the rtf file saved by the same version of the ODTfile
Comment 4 Vivian Bian 2008-09-12 05:24:43 EDT
Thanks for your reply,and I've attached the two files.Please check them.

Regards.
Comment 5 Caolan McNamara 2008-09-16 05:27:56 EDT
Indeed, now to find out if its the export or the import that's wrong
Comment 6 Caolan McNamara 2008-09-16 06:51:05 EDT
Export issue, patch filed upstream and checked into our own devel branch
Comment 7 Caolan McNamara 2009-03-12 06:10:09 EDT
committed for >= 2.3.0-6.11
Comment 11 errata-xmlrpc 2009-09-02 05:08:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1248.html

Note You need to log in before you can comment on or make changes to this bug.