Bug 462067 - Pulseaudio causing processor spikes
Pulseaudio causing processor spikes
Status: CLOSED DUPLICATE of bug 462200
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 08:17 EDT by Paul F. Johnson
Modified: 2008-10-24 16:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:53:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pulseaudio results (15.57 KB, text/plain)
2008-10-03 09:43 EDT, Paul F. Johnson
no flags Details
output of pulseaudio test (15.25 KB, application/octet-stream)
2008-10-19 06:15 EDT, antonio montagnani
no flags Details

  None (edit)
Description Paul F. Johnson 2008-09-12 08:17:35 EDT
Description of problem:
When using pulseaudio (and xmms, but also occurs with flash, mplayer and anything using pulseaudio), every 10 seconds or so there is a stop in the music and the processor usage spikes from between 0-1% on pulse audio up to between 30 and 40% for a second or 2 then returns to 0-1%

Version-Release number of selected component (if applicable):
0.9.12-4

How reproducible:
100%

Steps to Reproduce:
1. Ensure that pulse audio is running and play something
2.
3.
  
Actual results:
Every 10 seconds the music stops and the processor hits between 30 and 40%

Expected results:
No spikes

Additional info:
Comment 1 Lennart Poettering 2008-10-03 09:04:02 EDT
Please run "pulseaudio -vvv" in a terminal (a pulseaudio -k might be necessary before). And paste what that outputs when those "spikes" happen.
Comment 2 Lennart Poettering 2008-10-03 09:05:32 EDT
oh, and what driver is this? I am pretty sure this might actually be a duplicate of bug 462200.
Comment 3 Paul F. Johnson 2008-10-03 09:43:49 EDT
Created attachment 319363 [details]
Pulseaudio results
Comment 4 Paul F. Johnson 2008-10-03 09:45:19 EDT
The sound from xmms completely stops (it also happens for anything producing sound, but I use xmms the most often). I'm using a SoundBlaster card if that's of any use... emu10k1 by the looks of lsmod
Comment 5 Lennart Poettering 2008-10-03 16:30:27 EDT
I am pretty sure this is a driver bug in emu10k. Some fuckup in snd_pcm_update_avail() or snd_pcm_delay()
Comment 6 antonio montagnani 2008-10-19 06:15:30 EDT
Created attachment 320793 [details]
output of pulseaudio test

I am running on an Intel system.My profile is:
http://www.smolts.org/show?uuid=pub_2dabf29b-bd26-4825-b7ed-ac1db85fec24

Sometimes with older kernels I didn't suffer so heavy with this.Latest are a  disaster
Comment 7 antonio montagnani 2008-10-20 07:41:16 EDT
2.6.27.3-30.rc1.fc10.i686 kernel is playing fine.
Is it an issue with pulseaudio or the kernel???
Comment 8 Paul F. Johnson 2008-10-20 07:56:11 EDT
Looks like the kernel is at fault...
Comment 9 Lennart Poettering 2008-10-24 16:53:55 EDT
This sounds a lot like a duplicate of 462200.

*** This bug has been marked as a duplicate of bug 462200 ***

Note You need to log in before you can comment on or make changes to this bug.