Bug 462098 - Intel display hangs unless the system gets mouse/keyboard input
Intel display hangs unless the system gets mouse/keyboard input
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-09-12 11:32 EDT by Will Woods
Modified: 2013-01-09 23:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 18:30:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from stalled graphics system (23.59 KB, text/plain)
2008-09-15 13:07 EDT, Jarod Wilson
no flags Details
Xorg.0.log (24.55 KB, text/plain)
2008-09-15 14:39 EDT, Andrew Parker
no flags Details

  None (edit)
Description Will Woods 2008-09-12 11:32:37 EDT
With the current intel driver (xorg-x11-drv-i810-2.4.2-8.fc10.i386), Xorg seems to "hang" occasionally, until it gets input from the mouse or keyboard. Then it starts drawing again. Once the input stops the display draws for a bit, then hangs again.
Comment 1 Matěj Cepl 2008-09-12 12:31:50 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jarod Wilson 2008-09-15 13:07:54 EDT
Created attachment 316762 [details]
Xorg.0.log from stalled graphics system

I'm seeing identical behavior. Clean rawhide install from this past weekend on an Acer Aspire One. No xorg.conf whatsoever, here's the resulting log.
Comment 3 Jarod Wilson 2008-09-15 13:11:03 EDT
Some further info: Intel 945GME integrated graphics in this case. BIOS lists 8MB allocated for graphics (can't be altered).
Comment 4 Jarod Wilson 2008-09-15 14:24:30 EDT
Booting with pci=nomsi seems to help here.
Comment 5 Andrew Parker 2008-09-15 14:39:30 EDT
Created attachment 316770 [details]
Xorg.0.log

Xorg.0.log from a Dell Insprion 1420 with a "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)" that exhibits this problem with the same driver as the OP.  This system does not use an xorg.conf file.

pci=nomsi helps somewhat, but the display still hangs for me.
Comment 6 Dave Airlie 2008-09-15 19:58:41 EDT
please try -329 when it builds in koji.
Comment 7 Jarod Wilson 2008-09-15 23:34:37 EDT
Seems I was just lucky that one boot w/pci=nomsi, it doesn't seem to have made a difference on subsequent boots (nor did nohz=off). Trying 329 w/the updated intel irq handling patches momentarily... Okay, booted, and so far, looks like that did the trick. Noticeable improvement in graphics responsiveness across the board, and I have yet to encounter any stall-outs. Will keep an eye on it the next boot or three to be sure it isn't a fluke like nomsi. ;)
Comment 8 Sven Lankes 2008-09-16 02:56:45 EDT
(In reply to comment #6)

> please try -329 when it builds in koji.

That one fixes the issue for me.
Comment 9 Matěj Cepl 2008-09-16 10:32:21 EDT
Will? Does -329 help for you?
Comment 10 Will Woods 2008-09-17 11:27:08 EDT
This seems fixed with kernel -329.
Comment 11 Andrew Parker 2008-09-17 13:45:13 EDT
I don't get this any more with 329 either.
Comment 12 Jesse Keating 2008-09-23 18:30:19 EDT
329 is in the beta/rawhide, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.