Bug 462100 - RFE: fedorakmod.py should not allow kernel-headers/-docs/-devel to be updated
RFE: fedorakmod.py should not allow kernel-headers/-docs/-devel to be updated
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 12:36 EDT by Hans Ecke
Modified: 2008-09-30 17:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 17:39:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ecke 2008-09-12 12:36:46 EDT
Description of problem:

fedorakmod.py from yum-utils (distributed as the yum-fedorakmod package) has the option "pinkernels=1" which disables a kernel update unless updates for all installed modules are available also.

However, when disallowing such a kernel update, it only blocks the actual kernel package, and not other dependent packages like kernel-headers, kernel-docs and kernel-devel. It should.

Version-Release number of selected component (if applicable):

Rawhide (yum-utils 1.16 as of 12 Sept 2008)

How reproducible:

Always

Steps to Reproduce:
1. install yum-fedorakmod
2. set it's config to "pinkernels=1"
3. install kernel-doc, kernel-headers, kernel-devel
4. wait for a time when a new kernel package is out (for instance today's 2.6.26) and some of your installed modules are not yet repackaged. 
5. yum offers to _only_ update kernel-doc, -devel and -headers
  
Actual results:

After accepting, you have a package list like this:

kernel-2.6.25
kernel-doc-2.6.26
kernel-header-2.6.26
kernel-devel-2.6.25
kernel-devel-2.6.26

Expected results:

Yum does not offer to update any kernel packages, leaving us with a consisten set of

kernel-2.6.25
kernel-doc-2.6.25
kernel-header-2.6.25
kernel-devel-2.6.25

Additional info:

Sorry, no patch this time. Don't know python...
Comment 1 James Antill 2008-09-26 01:09:54 EDT
it only blocks the actual kernel package, and not other dependent packages like kernel-headers, kernel-docs and kernel-devel. It should.

...why should it? kernel-devel seems like the only one that _might_ be worth considering, but even then I'm not 100% sure it should be.
Comment 2 Hans Ecke 2008-09-30 11:50:53 EDT
James-

Why does this list of packages make sense to you?

   kernel-X
   kernel-doc-Y
   kernel-header-Y
   kernel-devel-X
   kernel-devel-Y

Why should I have kernel-doc and kernel-header installed for version Y, when I do not have version Y installed at all? Please note that kernel-doc-X and kernel-headers-X have been removed. I end up with a situation where I have kernel-doc installed for a different version than the kernel I am running. That might even lead to problems when I rely on information in the kernel docs that do not apply to my installed kernel.

Does this answer your question? I'm happy to expound further ...

Hans
Comment 3 James Antill 2008-09-30 13:13:29 EDT
 Because kernel-doc and kernel-headers don't depend on the version of the running (or installed) kernel, AIUI.
 So if you are, say, developing for RHEL-5 and running on Fedora 9 ... then AIUI you can just install the docs/devel sub. packages for the RHEL-5 version of the kernel, no?

 I appreciate that you don't think it's optimal in your case, but I'm really not sure that kmod should be _adding_ deps. to things instead of just obeying the ones that are there (it might well not do that, I don't know).
 In a similar way there are a bunch of packages where you can install a different foo and foo-devel, and it's not optimal ... but yum shouldn't be fixed to add deps. where there are none.
Comment 4 Hans Ecke 2008-09-30 15:55:22 EDT
Well, first we are not talking about standard yum but about an optional plugin. In other words, the local sysadmin has already requested a non-standard behavior.

Second, why are kernel-doc and kernel-headers not parallel-installable, just like kernel-devel? I would not mind so much if the package manifest after yum would be

   kernel-X
   [kernel-Y blocked by fedorakmod]
   kernel-doc-X
   kernel-doc-Y
   kernel-header-X
   kernel-header-Y
   kernel-devel-X
   kernel-devel-Y

At least that would be consistent. (I understand possible problems with multiple version of kernel-headers)

Lastly, I really don't want to argue with you. This bug/RFE is rather unimportant. If somebody could apply the patch from bug#462099 that would be a much bigger deal...

Thanks!

Hans
Comment 5 James Antill 2008-09-30 17:39:57 EDT
 You can change installonly local yourself ... rel-eng would need to be consulted to change the default for everyone.
Comment 6 Hans Ecke 2008-09-30 17:47:55 EDT
Fair enough. And this bug is documentation...

Have a good one

Hans

Note You need to log in before you can comment on or make changes to this bug.