Bug 46211 - System pauses when battery applet is updating (ThinkPad 240)
Summary: System pauses when battery applet is updating (ThinkPad 240)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-27 12:33 UTC by Stuart Fairley
Modified: 2007-04-18 16:34 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-07-02 08:46:09 UTC


Attachments (Terms of Use)

Description Stuart Fairley 2001-06-27 12:33:29 UTC
Description of Problem:
Running on an IBM ThinkPad 240, after starting X the system appears to
pause every few seconds (most noticeable when using the mouse, which just
stops moving).

How Reproducible:
Run a laptop install on a ThinkPad 240, run X, move the mouse around

Steps to Reproduce:
1.  Start X on IBM ThinkPad 240
2.  Move mouse around
3. 

Actual Results:
Mouse stops moving for a moment every few seconds (system stops
responding).

Expected Results:
System should run smoothly all the time and mouse motion should be smooth.

Additional Information:
After some investigation it appeared to be the battery applet which was
causing the problem - increasing the time between updates caused the pauses
to happen less often. Disabling the battery applet fixed the problem
completely.

Comment 1 Mike A. Harris 2001-06-29 21:25:15 UTC
Arjan, could this be kernel related?

Comment 2 Mike A. Harris 2001-06-29 21:54:11 UTC
Or more likely, a bug in the applet causing it to consume CPU and slow X
down.  Most probably not an XFree86 bug.

Comment 3 Arjan van de Ven 2001-07-02 08:46:05 UTC
Bios bug; some biosses take forever to determine batterystatus and the
battery applet then causes evil things ...

Comment 4 Stuart Fairley 2001-07-02 15:45:57 UTC
After Arjan's comment I checked the BIOS version and found there had been 14
releases since the version I had. I upgraded to the latest version (1.16) and
the applet doesn't appear to cause any degradation in performance now.

Thanks.



Note You need to log in before you can comment on or make changes to this bug.