Bug 462131 - NetworkManager does not apply all information received from DHCP server
NetworkManager does not apply all information received from DHCP server
Status: CLOSED DUPLICATE of bug 441453
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 17:00 EDT by Robert Banfield
Modified: 2008-10-19 23:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-19 23:00:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Banfield 2008-09-12 17:00:16 EDT
Description of problem: The DHCP server (dnsmasq) sends out an IP address, netmask, broadcast address, list of dns servers, hostname, dnsdomainname.  The hostname and dnsdomainname are not set by NetworkManager, and remain localhost.localdomain


Version-Release number of selected component (if applicable):
0.7.0-0.9.4.svn3675.


How reproducible: Always


Steps to Reproduce:
1. Configure a DHCP server to send out hostname+dnsdomainname
2. Boot a computer using dhcp (or restart NetworkManager)
3. 

  
Actual results: The hostname and dnsdomain are not set.  The IP address, netmask, broadcast address, and list of dns servers are set.


Expected results: The hostname, dnsdomain, IP address, netmask, broadcast address, and list of dns servers are set.


Additional info: DHCP server can correctly set this information on other machines.
Comment 1 Dan Williams 2008-10-19 23:00:12 EDT

*** This bug has been marked as a duplicate of bug 441453 ***

Note You need to log in before you can comment on or make changes to this bug.