Bug 462165 - Batteries are not managed properly
Batteries are not managed properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-13 04:11 EDT by Piotr Wojciechowski
Modified: 2008-10-04 11:44 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.26.5-28.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-04 11:44:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Wojciechowski 2008-09-13 04:11:19 EDT
Description of problem:

I have Compaq6715b laptop with two batteris - standard one and external one. After upgrading kernel system apps (kpowersave and gnome-power-manager) and showing that I have 4 batteries installed. Battery 2 is external battery (checked by removing it) and I guess battery 4 is standard one. Battery 1 and 3 are showing constant 98% charge level. Total level of charging and remaining time while working on batteries have nothing in common with real situation.

Here are some ACPI logs from dmesg:

ACPI: AC Adapter [C1EB] (off-line)
ACPI: Battery Slot [C1ED] (battery present)
ACPI: Battery Slot [C1EC] (battery present)

Version-Release number of selected component (if applicable):

This problem had been in early 2.6.25 kernels from Fedora packages, but has been solved. In kernel kernel-2.6.25.14-69.fc8.x86_64.rpm I had been using lately everything had been working properly. Now same problem occurs again. I am using latest kernel-2.6.26.3-14.fc8

How reproducible:

Boot latest kernel on Comapaq 6715b laptop
  
Actual results:

System apps displays 4 batteries and charge level and remaining time have nothing in common with real situation

Expected results:

Two batteries visible on system and proper charging level and display time returned.
Comment 1 Piotr Wojciechowski 2008-10-04 11:44:18 EDT
Seems to be fixed in kernel 2.6.26.5-28.fc8

Note You need to log in before you can comment on or make changes to this bug.