Bug 462167 - kernel-2.6.26.3-29.fc9 and IWL4965 break WPA
kernel-2.6.26.3-29.fc9 and IWL4965 break WPA
Status: CLOSED DUPLICATE of bug 458972
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-13 05:14 EDT by Luca Botti
Modified: 2008-11-11 14:32 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 10:22:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
egrep wlan0 /var/log/messages (37.06 KB, text/plain)
2008-09-18 22:56 EDT, gene c
no flags Details

  None (edit)
Description Luca Botti 2008-09-13 05:14:07 EDT
Description of problem:

Since updating to kernel-2.6.26.3-29.fc9.x86_64, i cannot connect to WPA protected networks. I have WPA both at work and at home, so it is quite a problem, now.


Version-Release number of selected component (if applicable):

kernel-2.6.26.3-29.fc9.x86_64
iwl4965-firmware-228.57.2.21-1.noarch


How reproducible:

update to said kernel


Steps to Reproduce:
1. Update
2. Reboot in the new kernel
3. Try connecting to a wpa encrypted wifi network
  
Actual results:

Unable to connect, /var/log/messages ends with

iwl4965: Error sending TX power (-22)




Expected results:

correct connection to the network


Additional info:
none
Comment 1 Kevin Kofler 2008-09-14 18:50:04 EDT
I can confirm flakiness with iwl4965, WPA and this kernel. I actually got a connection once, but lost it later. (First boot attempt: unable to connect entirely, second boot attempt: able to connect, transfer some files over SFTP, then lost connection while downloading updates and failed to reconnect.) I don't see any error messages which look useful to me in /var/log/messages. I ended up booting into the previous kernel, but this obviously isn't a fix.
Comment 2 Sjoerd Mullender 2008-09-15 15:14:45 EDT
Same problem here with kernel-2.6.26.3-29.fc9.x86_64.  When I boot kernel-2.6.25.14-108.fc9.x86_64 I can connect without problem.
Comment 3 Russell Harrison 2008-09-15 18:38:14 EDT
I've seen this behavior as well.  If I boot 2.6.25.14 everything is working properly.  Using 2.6.26.3 I am unable to connect to any wireless networks.

$ rpm -q kernel
kernel-2.6.25.11-97.fc9.i686
kernel-2.6.25.14-108.fc9.i686
kernel-2.6.26.3-29.fc9.i686

I'll be happy to provide any debugging assistance I can given direction.
Comment 4 Dax Kelson 2008-09-15 23:54:45 EDT
I can confirm this problem as well. However, I can't connect to *any* networks including:

* Unsecured WiFI network
* WEP network
* WPA2 secured network

Booting back to 2.6.25.14-108.fc9.x86_64 and they all work.
Comment 5 Kevin Kofler 2008-09-15 23:59:42 EDT
Right, it's not just WPA, I tried the university's 802.1x LEAP network yesterday and had the same problem. (I actually was able to connect, but then lost the connection after a few minutes and couldn't reconnect.)
Comment 6 gene c 2008-09-18 22:56:26 EDT
Created attachment 317148 [details]
egrep wlan0 /var/log/messages
Comment 7 gene c 2008-09-18 23:00:43 EDT
WHen i added attachment bugzilla deleted my  comments - trying again (see attachment above)

I confirm this with kernel-2.6.26.3-14.fc8 - totally unable to use the wireless.
I tried to connect a couple of times - even shutdown NM and nm-applet - then removed the iwl4965 module - turned off the radio kill switch and back on (this used to help a few months ago when I cud not connect then) - didnt help at all this time.

It appeared to connect - but I could not actually use the network.

I do have this in log (rest of log is above) :

kernel: wlan0 (WE) : Wireless Event too big (342)


Also with older kernel even - a large fraction of time - while it connects ok - it refuses to connect to the AP 6 inches from the laptop but chooses an alternate AP 100 feet away .. which is very odd.

Reverting to kernel-2.6.25.14-69.fc8 all works.

hope this is helpful
Comment 8 gene c 2008-09-19 07:37:32 EDT
I am not using x64 kernel- just i686.

gene
Comment 9 gene c 2008-10-02 20:18:55 EDT
Quick update - Still not working using 2.6.26.5 kernel.
Comment 10 Luca Botti 2008-10-03 03:25:20 EDT
Confirm: with latest update (2.6.26.5-45), no solution for the issue. Is anybody looking at it?
Comment 11 John W. Linville 2008-10-03 10:22:49 EDT
The same issue (i.e. unable to connect to WPA networks) seems to occur on F8, F9, and rawhide.  I have mostly concentrated on rawhide kernels so far, but not solution yet.  This does not seem to be confined to iwl4965 but instead seems to affect all mac80211-based drivers.

FWIW, a clean 2.6.27-rc8 kernel built w/ the rawhide kernel configuration does _NOT_ exhibit this problem (at least not for me), while the rawhide and F9 kernels clearly do (for me).  I do not see any wireless-related (or even crypto-related) difference between the rawhide kernels and the plain upstream kernels that would account for this behavior (or even suggest a link to it).

*** This bug has been marked as a duplicate of bug 458972 ***
Comment 12 Kevin Kofler 2008-10-03 10:29:14 EDT
WPA is WORKING with rt2x00's rt73usb (with the matching hardware, of course) on kernel-2.6.26.3-14.fc8. So it can't be all mac80211-based drivers.
Comment 13 John W. Linville 2008-10-03 11:02:34 EDT
Comment 12 is an interesting datapoint -- I'll try to confirm.  Nevertheless, it seems unlikely that we somehow broke WPA in multiple mac80211-based drivers simultaneously (and only in Fedora) in unrelated ways...
Comment 14 Kevin Kofler 2008-11-11 08:02:43 EST
Any updates on this? Current Fedora kernels not working with one of the most common wireless chipsets is really bad. I'm still stuck on kernel-2.6.25.14-108.fc9 on my laptop and I'm sure there are many more people with this problem. (And this is not just WPA - as I said, at least 802.1x LEAP is similarly broken.)
Comment 15 Kevin Kofler 2008-11-11 08:06:14 EST
Oops, I see there are some updates (but unfortunately still no solution) in bug 458972.
Comment 16 Mike C 2008-11-11 14:32:56 EST
I have been following this thread for some time - clearly some people have had very serious wireless connection issues with IWL4965 - however I have been running F9 for many months now with IWL4965 under F9 in Gnome using NetworkManager connecting with WPA2-PSK encryption - with not a single wireless problem all through the kernel changes from the 2.6.25 through to the current 2.6.26 kernels in F9.

The AP I am using is a Linksys WRT54GL and the encryption was until recently set to use "TKIP + AES". At the weekend I switched to "AES" only and the wireless remains solid.  My laptop in this case is a Dell M4300, and at all stages I have been running with fully updated F9. The AP is set to use BG Mixed mode.

There must be something to hook into in giving the information that my system works perfectly well whereas other combinations of hardware seem not to. Why should different combinations give different results?

Would it be related to which AP is being used I wonder?  I see a lot of people using the T61 and having problems. Are there any people running T61 who can connect using WPA?  

Anyone with the same combination as mine who see these issues?  My install was clean and I have made no adjustments at all to the networking setup - it connected first time without any special effort.

From comment #11 there is a suggestion that this may affect other mac8011-based drivers, but I have also been running an old laptop with F9 using the RT73usb in kernel driver to the same AP without issue also. Does this help?

In addition another machine using IWL3945 in kernel driver in F8 has been connecting to the same AP without any issues as well.....

Would be nice to know if there is some information that might give a lead in finding where the problem really lies?

Note You need to log in before you can comment on or make changes to this bug.