Bug 46217 - startx and Xwrapper problem and solution
Summary: startx and Xwrapper problem and solution
Status: CLOSED DUPLICATE of bug 46218
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-27 12:50 UTC by Chris Bitmead
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-27 12:50:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Bitmead 2001-06-27 12:50:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; m18)
Gecko/20001123

Description of problem:
I can't see how startx ever could have worked in RH7.0,
nevertheless, this is what it took to get it working for me.
Change line 33 in startx to say server= instead of serverargs=
Otherwise the args end up in the wrong order down the bottom
with display coming before the server which is wrong. Then
X must be a symlink to the specific X server I am using
(i.e. not a link to Xwrapper.). Then there must be a
xserverrc file that execs Xwrapper. The final outcome here
is that startx execs xserverrc which execs Xwrapper which
execs X which is a symlink to my accelerated server.
Having X a symlink to Xwrapper doesn't seem to work because
Xwrapper doesn't know which accel server to start.

How reproducible:
Always

Steps to Reproduce:
1. default RH7.0 startx doesn't start, just hangs.
2.
3.
	

Additional info:

Comment 1 David Lawrence 2001-06-27 13:29:13 UTC

*** This bug has been marked as a duplicate of 46218 ***


Note You need to log in before you can comment on or make changes to this bug.