Bug 462185 - You need at least driver version 0.14.4??
You need at least driver version 0.14.4??
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ksynaptics (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
: 464423 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-13 11:42 EDT by Reindl Harald
Modified: 2013-01-13 08:14 EST (History)
6 users (show)

See Also:
Fixed In Version: 0.14.6c-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 13:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2008-09-13 11:42:19 EDT
Hi

Since upgrade to Fedora9 ksynaptics stopped working and brings the error-message from subject.

I'm running now the latest synapics-builds from koji, but the same result
Seems that the drivers are to new for the ksynaptics build because they are > 0.4.14

[harry@nb-rhsoft:~]$ rpm -qa | grep synaptics
libsynaptics-0.14.6c-3.fc9.i386
ksynaptics-0.3.3-5.fc9.i386
xorg-x11-drv-synaptics-0.15.1-1.fc9.i386
Comment 1 Steven M. Parrish 2008-09-28 16:47:17 EDT
*** Bug 464423 has been marked as a duplicate of this bug. ***
Comment 2 Linuxguy123 2008-11-27 10:08:28 EST
I have the same problem in F10.  I'd like someone to bump the version of this bug to F10 so that it gets more priority.   Ksynaptics and the synaptic drivers worked fine for me in F8.

$ yum list *synaptics*
Loaded plugins: kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Installed Packages
ksynaptics.i386                             0.3.3-7.fc10               installed
libsynaptics.i386                           0.14.6c-5.fc10             installed
xorg-x11-drv-synaptics.i386                 0.15.2-1.fc10              installed


In the Information frame, ksynaptics states "Using libsynaptics version: 0.14.6c" and "Using driver version 0.15.2"  So the application knows the versions of the drivers installed and libsynaptics is > 0.14.4.

I hope this gets attention very soon as this is the only way I can turn off the touchpad on my laptop and its irritating to have it on when I am typing because I frequently accidentally move the cursor.  Its a big pain.
Comment 3 Linuxguy123 2008-12-04 22:33:24 EST
This bug should be bumped to F10, as I have this problem in F10.

I don't know if its related, but if I select "Configure Synaptics Touchpad", an SELinux alert gets generated:


Summary:

SELinux is preventing gnome-power-man (xdm_t) "execute" to /dev/zero
(zero_device_t).

Detailed Description:

SELinux denied access requested by gnome-power-man. It is not expected that this
access is required by gnome-power-man and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for /dev/zero,

restorecon -v '/dev/zero'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:zero_device_t:s0
Target Objects                /dev/zero [ chr_file ]
Source                        gnome-power-man
Source Path                   /usr/bin/gnome-power-manager
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           gnome-power-manager-2.24.1-3.fc10
Target RPM Packages           
Policy RPM                    selinux-policy-3.5.13-26.fc10
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 2.6.27.5-117.fc10.i686
                              #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686
Alert Count                   1
First Seen                    Wed 03 Dec 2008 11:28:39 PM EST
Last Seen                     Wed 03 Dec 2008 11:28:39 PM EST
Local ID                      9e16dabd-6c7f-4ae4-98aa-980f4c9a1314
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1228364919.233:161): avc:  denied  { execute } for  pid=22468 comm="gnome-power-man" path="/dev/zero" dev=tmpfs ino=383 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:zero_device_t:s0 tclass=chr_file

node=localhost.localdomain type=SYSCALL msg=audit(1228364919.233:161): arch=40000003 syscall=192 success=no exit=-13 a0=0 a1=2000 a2=7 a3=2 items=0 ppid=22467 pid=22468 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="gnome-power-man" exe="/usr/bin/gnome-power-manager" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

I'd really like this fixed or a work around implemented because I now have no way to turn off the touchpad on my laptop and I frequently brush it accidentally while I am typing.  Its a constant pain in the butt. 

Thanks
Comment 4 Ryan Rix 2008-12-05 20:04:33 EST
This needs to be filed against selinux-policy. Be sure to search before you file though ;)

(In reply to comment #3)
> SELinux alert gets generated:
> 
> 
> Summary:
> 
> SELinux is preventing gnome-power-man (xdm_t) "execute" to /dev/zero
> (zero_device_t).
> 
> Detailed Description:
> 
> SELinux denied access requested by gnome-power-man. It is not expected that
> this
> access is required by gnome-power-man and this access may signal an intrusion
> attempt. It is also possible that the specific version or configuration of the
> application is causing it to require additional access.
> 
> Allowing Access:
> 
> Sometimes labeling problems can cause SELinux denials. You could try to restore
> the default system file context for /dev/zero,
> 
> restorecon -v '/dev/zero'
> 
> If this does not work, there is currently no automatic way to allow this
> access.
> Instead, you can generate a local policy module to allow this access - see FAQ
> (http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
> SELinux protection altogether. Disabling SELinux protection is not recommended.
> Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
> against this package.
> 
> Additional Information:
> 
> Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
> Target Context                system_u:object_r:zero_device_t:s0
> Target Objects                /dev/zero [ chr_file ]
> Source                        gnome-power-man
> Source Path                   /usr/bin/gnome-power-manager
> Port                          <Unknown>
> Host                          localhost.localdomain
> Source RPM Packages           gnome-power-manager-2.24.1-3.fc10
> Target RPM Packages           
> Policy RPM                    selinux-policy-3.5.13-26.fc10
> Selinux Enabled               True
> Policy Type                   targeted
> MLS Enabled                   True
> Enforcing Mode                Enforcing
> Plugin Name                   catchall_file
> Host Name                     localhost.localdomain
> Platform                      Linux localhost.localdomain
> 2.6.27.5-117.fc10.i686
>                               #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686
> Alert Count                   1
> First Seen                    Wed 03 Dec 2008 11:28:39 PM EST
> Last Seen                     Wed 03 Dec 2008 11:28:39 PM EST
> Local ID                      9e16dabd-6c7f-4ae4-98aa-980f4c9a1314
> Line Numbers                  
> 
> Raw Audit Messages            
> 
> node=localhost.localdomain type=AVC msg=audit(1228364919.233:161): avc:  denied
>  { execute } for  pid=22468 comm="gnome-power-man" path="/dev/zero" dev=tmpfs
> ino=383 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
> tcontext=system_u:object_r:zero_device_t:s0 tclass=chr_file
> 
> node=localhost.localdomain type=SYSCALL msg=audit(1228364919.233:161):
> arch=40000003 syscall=192 success=no exit=-13 a0=0 a1=2000 a2=7 a3=2 items=0
> ppid=22467 pid=22468 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42
> egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="gnome-power-man"
> exe="/usr/bin/gnome-power-manager" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023
> key=(null)
> 
> I'd really like this fixed or a work around implemented because I now have no
> way to turn off the touchpad on my laptop and I frequently brush it
> accidentally while I am typing.  Its a constant pain in the butt. 
> 
> Thanks
Comment 5 Orion Poplawski 2008-12-19 10:59:42 EST
Upstream on this project is completely dead.  I'm not sure I'm ready to become the full maintainer for this, and any help is appreciated.  However,  I've got some updates to test.  

Please file a separate bug for the selinux issue, esp. since it seems to relate to gnome-power-manager and not ksynaptics.
Comment 6 Fedora Update System 2008-12-19 11:00:36 EST
libsynaptics-0.14.6c-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libsynaptics-0.14.6c-6.fc9
Comment 7 Fedora Update System 2008-12-19 11:01:33 EST
libsynaptics-0.14.6c-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libsynaptics-0.14.6c-6.fc10
Comment 8 Fedora Update System 2008-12-21 03:31:55 EST
libsynaptics-0.14.6c-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update libsynaptics'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11533
Comment 9 Fedora Update System 2008-12-21 03:33:27 EST
libsynaptics-0.14.6c-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libsynaptics'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11620
Comment 10 Reindl Harald 2008-12-21 19:23:12 EST
I have installed "libsynaptics-0.14.6c-6.fc10.i386" now
At first look it seems to work and the error-message is away

But:
"STRG+ALT+Q" shows that i disable/enable the touchpad
But even if it should be disabled it works again, this is the most useful function because notebook-vendors seems to be too stupid for making a hardware-switch and its a pain to touch it while typing and do anything unwanted at this time :-(
Comment 11 Fedora Update System 2009-03-11 13:56:52 EDT
libsynaptics-0.14.6c-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-03-11 14:04:14 EDT
libsynaptics-0.14.6c-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.