Bug 462201 - kernel-2.6.26.3-29.fc9.x86_64 won't boot
kernel-2.6.26.3-29.fc9.x86_64 won't boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-13 18:15 EDT by Neal Becker
Modified: 2009-07-14 12:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-09-13 18:15:28 EDT
Description of problem:
Just hangs at "booting kernel".  Bottom of screen says "kernel alive".  I'd hate to see dead.  No other messages.

This is HP 9v9500

Version-Release number of selected component (if applicable):


How reproducible:

Tried 2 times

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2008-09-13 21:11:33 EDT
Please replace 'quiet' with 'ignore_loglevel' in the kernel boot options in grub.conf and see where it hangs.
Comment 2 Neal Becker 2008-09-15 07:46:18 EDT
Haven't tried that yet, but I do want to report that this is definately RANDOM.  This morning I tried to boot normally and it hung.  Then I forced power off, tried again and it booted normally.

Never saw this behavior with any earlier kernel.
Comment 3 Michael Jones 2008-09-15 16:23:19 EDT
I can confirm that this same thing happens on a HP dv8110us. Also, the Kernel installs, but does not update the grub.conf file. I had to do that manually.

The kernel fails at:

  Creating root device.
  Mounting root filesystem.
  mount: could not find filesystem '/dev/root'
  Setting up other filesystems.
  Setting up new root fs
  setuproot: moving /dev/failed: No such file or directory
  no fstab.sys, mounting internal defaults
  setuproot: error mounting /proc: No such file or directory
  setuproot: error mounting /sys: No such file or directory
  Mount failed for selinuxfs on /selinux: No such file or directory
  Switching to new root and running init.
  unmounting old /dev
  unmounting old /proc
  unmounting old /sys
  switchroot: mount failed: No such file or directory
  Booting has failed

and there is hangs until you reboot into old kernel, which works fine.
Comment 4 Neal Becker 2008-09-15 16:58:59 EDT
I don't think this is the same as mine.  Mine never even starts nash, (unless the quiet option now quiets that line, which it never did before).
Comment 5 my_linux 2008-09-19 04:27:12 EDT
The same is also happening on my Dell XPS M1530 using Fedora x86_64. It is also rather random but commonly happens after a cold boot rather then a restart.
Comment 6 Marcos Martins da Silva 2008-09-22 20:27:24 EDT
Hi Michael, I had similar messages when booting the new kernel on a system with "/" partitioned as ext4. However, this same machine with 2.6.25.14-108 boots fine, just like yours. Are you using ext4?
Comment 7 Michael Jones 2008-09-22 23:44:22 EDT
no, ext3
Comment 8 Henrik Nordström 2008-10-01 17:05:25 EDT
I see the same with current rawhide kernels on my Laptop. 

If I remove the quiet option there is about a screenful of messages and it then hangs at 

  PCI: Using MMCONFIG for extended config space
  PCI: Using configuration type 1 for base access

and the fan quickly speeds up to max speed.

When it works the next message (after a brief pause) is

  ACPI: BIOS _OSI(Linux) query ignored via DMI
  ACPI: Interpreter enabled

This is seen with both x86_64 and i686 kernels.
Comment 9 Henrik Nordström 2008-12-07 17:03:15 EST
The Fedora 10 kernel do work fine on my laptop.
Comment 10 Bug Zapper 2009-06-09 22:42:33 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-07-14 12:44:08 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.