Bug 462206 - RFE: please support "check" and "cross" characters in PDF
RFE: please support "check" and "cross" characters in PDF
Status: CLOSED WONTFIX
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Michael Hideo
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 01:12 EDT by Murray McAllister
Modified: 2015-01-04 17:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-12 19:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results from make html and make pdf (927 bytes, application/x-gzip)
2008-09-14 01:12 EDT, Murray McAllister
no flags Details

  None (edit)
Description Murray McAllister 2008-09-14 01:12:00 EDT
Created attachment 316679 [details]
results from make html and make pdf

Description of problem:

"✓" and "✗" appear as squares in PDF builds. Works in HTML.


Version-Release number of selected component (if applicable):

* Red Hat Enterprise Linux Client release 5.2 (Tikanga)
* publican-0.37-0.el5
* saxon-6.5.5-1jpp.3.el5
* fop-0.95-0.2.beta1.rh1.el5
* evince-0.6.0-8.el5
* Firefox 3.0.1 (from <http://www.mozilla.com/en-US/>)

How reproducible:

Always.

Steps to Reproduce:

1. Use "&check;" and "&cross;" in a document.
2. make html-en-US; make pdf-en-US
  
Actual results:

* check and cross characters appear in HTML build.
* squares where check and cross characters should be in PDF build.

See results.tar.gz for HTML and PDF output images.

Expected results:
* check and cross characters in PDF, please.

Additional info:

* issue is not brand-dependent.

* occurs when used in and out of tables.

* the HTML and HTML-single outputs from a document with "&check;" and "&cross;" are XHTML 1.0 Strict according to <http://validator.w3.org/>.

* <http://www.oasis-open.org/docbook/specs/wd-docbook-xmlcharent-0.3.html>
Comment 1 Murray McAllister 2008-10-04 00:55:05 EDT
Hi,

Any updates on whether this is possible, and if it is, when to expect check and cross to be supported in PDF?

Thanks!
Comment 2 Jeff Fearn 2008-10-06 02:17:37 EDT
The check and cross entities are not in the liberation fonts. Since FOP can not do per glyph font selection the PDF can not fall back to another font like the HTML renderers can.

It may be possible to use a tag or attribute specifically to override the font used, however this would be messy so you'd need to get some community consensus on how that would be done.

It may be easier to get the liberation maintainers to add these glyphs to the font :)
Comment 3 Jeff Fearn 2008-10-12 19:51:50 EDT
This is not a bug in publican and should be fixed in either the font or FOP. Please open a bug against either of those components if you feel it's required.

Note You need to log in before you can comment on or make changes to this bug.