This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 462221 - %post failure when installed via anaconda
%post failure when installed via anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: darcs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Hinegardner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 10:01 EDT by Jon Stanley
Modified: 2008-11-07 00:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 00:20:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Stanley 2008-09-14 10:01:02 EDT
restorecon is not found on line 2 of %post, therefore the script fails. 

Thanks!
Comment 1 Mamoru TASAKA 2008-09-19 06:20:25 EDT
Petersen-san:

While I don't know well about anaconda and I am not the user of darcs:

It seems that you changed to use full paths for semanage and so on, however it is
strange because (I was told that) rpm ensures that /sbin or /usr/sbin and so on
are in the paths when scriptlets are done:
http://www.redhat.com/archives/fedora-packaging/2007-August/msg00085.html

Rather I guess because this is due to the missing of "Requires(post): policycoreutils"
(currently "Requires(post): coreutils" is there, however I think this is a typo).
Comment 2 Jon Stanley 2008-09-22 00:20:12 EDT
Yeah, all that anaconda does is do a yum transaction. What I'm trying to say here is that during initial installation, on a fresh system, if you install darcs, there's a %post failure (I forget what the exact failure is, that system isn't around any longer).

If I recall, though, most of them were something about gtk-update-icon or something (not sure exactly).

I'll reproduce this test again with beta and let you know exactly what happened.
Comment 3 Jens Petersen 2008-09-22 03:36:38 EDT
(In reply to comment #1)
> Rather I guess because this is due to the missing of "Requires(post):
> policycoreutils"

Ah thanks I see.  Should be better in darcs-2.0.2-3.fc10.

Note You need to log in before you can comment on or make changes to this bug.