Bug 462227 - Error when using python-cjson package 1.0.5-1.fc8
Error when using python-cjson package 1.0.5-1.fc8
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-cjson (Show other bugs)
8
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 11:28 EDT by Clodoaldo Pinto Neto
Modified: 2008-09-14 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-14 12:52:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clodoaldo Pinto Neto 2008-09-14 11:28:43 EDT
When i install python-cjson 1.0.5-1 from Fedora 8 package i get this error:

>>> cjson.encode('é', encoding='utf8')

Traceback (most recent call last):
 File "<stdin>", line 1, in <module>
TypeError: encode() takes no keyword arguments

But when installed from source it works:

>>> cjson.encode('é', encoding='utf-8')
'"\\u00e9"'
Comment 1 Clodoaldo Pinto Neto 2008-09-14 12:52:29 EDT
Indeed the version i installed from source was 1.0.3 so this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.