Bug 462229 - iSCSI disks do not show up after hitting 'Add iSCSI target' (and filling in the right entries)
iSCSI disks do not show up after hitting 'Add iSCSI target' (and filling in t...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 11:48 EDT by Konrad Rzeszutek Wilk
Modified: 2008-09-14 16:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-14 16:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konrad Rzeszutek Wilk 2008-09-14 11:48:40 EDT
Description of problem:

This works just fine under RHEL5.2 with the same exact machine so it is not a setup issue.

The issue is that the newly added SCSI disks does not show up in the disk view. It looks as if the routine that rescans for all the disks on the system is not called.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot F9  install
2. Hit 'Add iSCSI target'
3. Fill in the entries with the right IP (and obviously have the IQN or the IP configured in the target).
4. See it says 'Initializaing iSCSI'
5. No disk shows up in the hard-disk view.
6. Switch to VC 4 and sure enough the SCSI disks is there.

 
If I do the manual iSCSI login before progressing in the graphical/VNC window the disk shows up. Those steps are obviously a hack:

#mkdir -p /etc/iscsi
#cat > /etc/iscsi/initiarname.iscsi
InitiatorName=iqn.2008.something:blah
#iscsiadm -m discovery -t st -p <IP>
#iscsiadm -m node -L all

And then go in the graphical view, and the iSCSI disk is there.

Expected results:

Step 5 should show the disk.

Additional info:
Comment 1 Hans de Goede 2008-09-14 16:23:10 EDT
Thanks for reporting!

This is a know issue with Fedora-9 which has been fixed in the F-10 alpha and the upcoming F-10 beta.

Note You need to log in before you can comment on or make changes to this bug.