Bug 462230 - a terminal appears instead of wings when using the XFCE menu
a terminal appears instead of wings when using the XFCE menu
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wings (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 11:55 EDT by François Cami
Modified: 2008-09-17 00:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 00:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description François Cami 2008-09-14 11:55:29 EDT
Description of problem:
  Selecting "Graphics/Wings 3D" in the XFCE menu results in launching the Terminal application.

Version-Release number of selected component (if applicable):
  wings-0.99.02-2.fc9.i386

How reproducible:
  Always

Steps to Reproduce:
1. right-click on XFCE background to use the menu
2. select Graphics
3. select Wings 3D
  
Actual results:
 The application selected as terminal in XFCE is launched.


Expected results:
 Wings3D should be launched.

Additional info:
This patch solves the problem.

--- /usr/share/applications/fedora-wings.desktop~       2008-09-14 17:36:58.000000000 +0200
+++ /usr/share/applications/fedora-wings.desktop        2008-09-14 17:36:58.000000000 +0200
@@ -5,5 +5,5 @@
 Exec=wings
 Icon=wings.png
-Terminal=true
+Terminal=false
 Type=Application
 Encoding=UTF-8

The problem seems XFCE-related : setting Terminal=true in pidgin's desktop file reproduces the problem as well, so I am going to open a bug against XFCE as well. The fact is, wings is the only application in my system to ship with a Terminal=true entry in its desktop file.
Comment 1 François Cami 2008-09-14 12:03:19 EDT
Note, this is only reproductible if the Terminal set in XFCE's "Preferred Applications" is KDE's konsole ; everything works as expected with XFCE's Terminal.
Comment 2 François Cami 2008-09-14 12:21:31 EDT
Since this seems to be related to using XFCE + Konsole, I've opened https://bugzilla.redhat.com/show_bug.cgi?id=462232 .
Please feel free to close this bug if Wings 3D really needs being launched in a Terminal.
Comment 3 François Cami 2008-09-17 00:16:17 EDT
Closing, because using 
konsole -e '%s' 
instead of 
konsole "%s"
makes Wings work again. However I still do not see why it needs to be opened in a Terminal, except for the debug information.

Note You need to log in before you can comment on or make changes to this bug.