Bug 462245 - ChannelDetails.do is slow to display when many package are in channel
ChannelDetails.do is slow to display when many package are in channel
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Red Hat Satellite QA List
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-09-14 14:25 EDT by John Matthews
Modified: 2009-09-17 03:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:01:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2008-09-14 14:25:12 EDT
Description of problem:

Display channel details is slow on channels with many packages.  With a fedora9 channel with around 9000 packages I'm seeing the channel details page take minutes to display.  Example when running over VPN this is taking over 5 minutes to display.  When running with a local DB connection it's taking over 1 minute to display.

Version-Release number of selected component (if applicable):
Spacewalk 0.2

How reproducible:
Always

Steps to Reproduce:
1. Create a custom channel with over 9000 packages
2. View channel details, ChannelDetails.do
3. 
  
Actual results:
With a local connection it takes about a minute or more to load

Expected results:
Should load quicker

Additional info:
I think this might be slow because of the below line in ChannelDetailsAction.java:

request.setAttribute("pack_size", chan.getPackages().size());
Comment 1 John Matthews 2008-09-18 11:07:38 EDT
Justin addressed this with commit:

http://git.fedoraproject.org/git/?p=spacewalk.git;a=commitdiff;h=f78241a84cac7b5cca0a9cb66b9cbd167df2313f

This is in 'master' and will be part of sw 0.3
Comment 2 Brad Buckingham 2008-11-05 09:23:12 EST
Verified on spacewalk-java-0.3.7-1.el5.sw.

Loading of channel details for F9 channel with 12K+ packages took less than 1 minute.
Comment 3 Miroslav Suchý 2009-09-17 03:01:43 EDT
Spacewalk has been released for some time.

Note You need to log in before you can comment on or make changes to this bug.