Bug 462344 - Searching for ! CC'ed ... doesn't work
Searching for ! CC'ed ... doesn't work
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-15 11:28 EDT by Chris Ward
Modified: 2013-06-24 00:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 12:41:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 458666 None None None Never

  None (edit)
Description Chris Ward 2008-09-15 11:28:18 EDT
Description of problem:
When I search for all bugs which cward@redhat.com is not CC'ed in, I get a full list of bugs which I *am* cc'ed in. I've tried both Boolean Query and non-boolean advanced query methods from the web-interface and xmlrpc.

Version-Release number of selected component (if applicable):
Current production 3.2

How reproducible:
always

Steps to Reproduce:
1.Open up advanced query page
2.Select RHEL 5 (to limit results)
3.Add Partner to keywords field
4. Add new boolean search
  CC - Does Not Contain String - cward@redhat.com
5. Search
6. Check bugs returned for CC:cward@redhat.com
  
Actual results:
Returns bugs which have CC:cward@redhat.com

Expected results:
Returns bugs which don't have CC:cward@redhat.com

Additional info:
Comment 1 Noura El hawary 2008-10-02 02:18:56 EDT
Thanks for reporting this issue problem has been verified, and working currently on a solution.

Noura
Comment 2 Chris Ward 2008-10-02 02:35:09 EDT
Glad to hear! Thanks for getting right on it. It's important for me to have this functionality for my bug tracking requirements.
Comment 3 Noura El hawary 2008-10-06 00:02:53 EDT
This is an upstream bug as well.

Noura
Comment 4 David Lawrence 2008-10-06 12:41:23 EDT
This is not a bug and should instead be done as described below:

Thanks
Dave

Upstream comment as they closed the bug:

This is working fine. As described in upstream bug 72977, you cannot use "doesn't
contain" as all bugs with 2+ users in the CC list would be returned (because
there is at least one other user in the CC list, which would match "doesn't
contain"). What you have to do is to use "NOT CC contains foo@bar.com", which
returns the expected list. I tested on b.m.o, which runs 3.2rc1+.

Note You need to log in before you can comment on or make changes to this bug.