Bug 462378 - PackageKit won't open after being closed while installing a software
PackageKit won't open after being closed while installing a software
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-15 14:56 EDT by Florent Le Coz
Modified: 2008-10-27 09:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 09:06:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florent Le Coz 2008-09-15 14:56:20 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b1pre) Gecko/20080915020339 Minefield/3.1b1pre

Using PackageKit Version 0.2.5.

If you close Packagekit while it is installing something (any package), i.e. both windows: the little with installation progress bar AND the main PackageKit window. Then the installation ends correctly, but you can't start PackageKit again afterward.

It happens only if you close PackageKit AFTER having agreed to the Dependencies installation. If you close packagekit BEFORE, you will be prompted for the depencies to check, if you agree, the installation ends correctly and you CAN actually launch packagekit.

When it happens (i.e. PackageKit can't be started anymore), pkmon hangs on:
"unlocked" and I can't see no other log or error message...

Reproducible: Always

Steps to Reproduce:
1. Open packagekit, select a package and launch the installation
2. Wait for dependencies window to pop-up (if any), agree
3. Close (quickly) all packagekit windows before the installation finish
4. Once it's finished, try to open PackageKit again
5. Fail, nothing happens
Actual Results:  
PackageKit can't be started anymore, you have to restart the session.

Expected Results:  
Packagekit should be able to restart.

Tasks:
[none]...
Tasks:
/31_edacaadc_data	remove-packages:wait thunderbird;2.0.0.16-1.fc9;x86_64;installed
locked
Tasks:
/31_edacaadc_data	remove-packages:running thunderbird;2.0.0.16-1.fc9;x86_64;installed
Tasks:
/31_edacaadc_data	remove-packages:dep-resolve thunderbird;2.0.0.16-1.fc9;x86_64;installed
unlocked
Tasks:
/31_edacaadc_data	remove-packages:download thunderbird;2.0.0.16-1.fc9;x86_64;installed
locked
Tasks:
/31_edacaadc_data	remove-packages:test-commit thunderbird;2.0.0.16-1.fc9;x86_64;installed
Tasks:
/31_edacaadc_data	remove-packages:remove thunderbird;2.0.0.16-1.fc9;x86_64;installed
Tasks:
/31_edacaadc_data	remove-packages:finished thunderbird;2.0.0.16-1.fc9;x86_64;installed
unlocked
Comment 1 Richard Hughes 2008-09-17 04:24:24 EDT
Can you please provide the output of:

gpk-application --verbose

When you have closed the window and got it in this stuck state. Thanks.
Comment 2 Florent Le Coz 2008-09-18 19:48:54 EDT
Ok, I think the problem is simple : gpk-application doesn't quit after the installation.

I processed like that :

Installation of 3 softwares, Packagekit asks for the dependencies, I agree, I then close all Packagekit windows, I wait until it finished (no message at all, just the systray icon that disappear) and then :

louiz@localhost ~> gpk-application --verbose
TI:01:36:43	TH:0x10855a0	FI:pk-debug.c	FN:pk_debug_init,255
 - Verbose debugging 1 (on console 1)
** (gpk-application:17467): DEBUG: You have another instance running. This program will now close



louiz@localhost ~> pkill gpk-application



louiz@localhost ~> gpk-application --verbose
TI:01:38:39	TH:0x210b5a0	FI:pk-debug.c	FN:pk_debug_init,255
 - Verbose debugging 1 (on console 1)
TI:01:38:39	TH:0x210b5a0	FI:pk-connection.c	FN:pk_connection_connection_changed_cb,129
 - emit connection-changed: 1
TI:01:38:39	TH:0x210b5a0	FI:pk-client.c	FN:pk_client_connect,3520
 - connect
TI:01:38:39	TH:0x210b5a0	FI:pk-client.c	FN:pk_client_connect,3520
 - connect
[...blablabla, OK, I'm running]


then I installed a software again with gpk-application in verbose mode, when it finished :

TI:01:46:17	TH:0x210b5a0	FI:gpk-animated-icon.c	FN:gpk_animated_icon_update,127
 - polling check
TI:01:46:17	TH:0x210b5a0	FI:gpk-animated-icon.c	FN:gpk_animated_icon_update,127
 - polling check
TI:01:46:18	TH:0x210b5a0	FI:gpk-animated-icon.c	FN:gpk_animated_icon_update,127
 - polling check
TI:01:46:18	TH:0x210b5a0	FI:pk-client.c	FN:pk_client_allow_cancel_cb,720
 - emit allow-cancel 0
TI:01:46:18	TH:0x210b5a0	FI:pk-client.c	FN:pk_client_change_status,526
 - emit status-changed finished
TI:01:46:18	TH:0x210b5a0	FI:gpk-animated-icon.c	FN:gpk_animated_icon_enable_animation,174
 - ignoring stop on stopped icon
TI:01:46:18	TH:0x210b5a0	FI:pk-control.c	FN:pk_control_locked_cb,651
 - emit locked 0
TI:01:46:18	TH:0x210b5a0	FI:pk-client.c	FN:pk_client_finished_cb,490
 - emit finished success, 127087
TI:01:46:18	TH:0x210b5a0	FI:gpk-animated-icon.c	FN:gpk_animated_icon_enable_animation,174
 - ignoring stop on stopped icon
TI:01:46:18	TH:0x210b5a0	FI:gpk-client.c	FN:gpk_client_finished_cb,492
 - quitting due to finished
TI:01:46:18	TH:0x210b5a0	FI:gpk-client.c	FN:gpk_client_main_quit,202
 - not already started!
TI:01:46:18	TH:0x210b5a0	FI:pk-control.c	FN:pk_control_transaction_list_changed_cb,577
 - emit transaction-list-changed
TI:01:46:23	TH:0x210b5a0	FI:pk-control.c	FN:pk_control_updates_changed_cb,614
 - emitting updates-changed
TI:01:46:23	TH:0x210b5a0	FI:pk-control.c	FN:pk_control_transaction_list_changed_cb,577
 - emit transaction-list-changed
TI:01:46:31	TH:0x210b5a0	FI:pk-control.c	FN:pk_control_locked_cb,651
 - emit locked 1
TI:01:46:31	TH:0x210b5a0	FI:pk-control.c	FN:pk_control_locked_cb,651
 - emit locked 0
TI:01:46:31	TH:0x210b5a0	FI:pk-control.c	FN:pk_control_transaction_list_changed_cb,577
 - emit transaction-list-changed


(note that " - not already started!" is in red)

Here is all the details I could get
Comment 3 Richard Hughes 2008-10-09 12:28:20 EDT
Can you reproduce this with rawhide or a F10 beta livecd?
Comment 4 Florent Le Coz 2008-10-09 13:41:25 EDT
I tested it on Rawhide (updated today) and I couldn't reproduce.

So, I think it's fixed in rawhide somehow :-)
Comment 5 Richard Hughes 2008-10-27 09:06:45 EDT
Okay, thanks.

Note You need to log in before you can comment on or make changes to this bug.