Bug 462414 - /etc/init.d/opensm is broken
/etc/init.d/opensm is broken
Product: Fedora
Classification: Fedora
Component: opensm (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-09-15 21:51 EDT by Ed Hill
Modified: 2009-01-09 02:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 02:52:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch to the opensm init file (1.05 KB, patch)
2008-09-15 21:55 EDT, Ed Hill
no flags Details | Diff

  None (edit)
Description Ed Hill 2008-09-15 21:51:48 EDT
The /etc/init.d/opensm script does not work.
Comment 1 Ed Hill 2008-09-15 21:55:35 EDT
Created attachment 316799 [details]
patch to the opensm init file

Hi Doug, I'm sorry for not catching this during the review.  In any case, 
changing just a few lines in the init file has opensm working for me on a 
cluster running F8 x86_64.
Comment 2 Doug Ledford 2008-09-16 23:08:45 EDT
I checked a new opensm.init script into the devel branch of CVS.  Can you check the script in your F8 environment and make sure it works there too?  Thanks.
Comment 3 Ed Hill 2008-09-17 09:07:37 EDT
OK, I tried the /cvs/pkgs/rpms/opensm/devel/opensm.initd (v1.2) on an F8 
system and the start, stop, status, and restart options all worked nicely
for me.  Thank you!
Comment 4 Bug Zapper 2008-11-26 06:09:17 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 5 Bug Zapper 2009-01-09 02:52:24 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.