Bug 462438 - Norwegian default locale not working correctly
Norwegian default locale not working correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 05:44 EDT by Kjartan Maraas
Modified: 2009-04-29 10:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 10:09:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2008-09-16 05:44:38 EDT
Description of problem:

If I start xterm from a gnome session I see this:


Version-Release number of selected component (if applicable):

[kmaraas@localhost po-locations]$ xterm
Warning: locale not supported by Xlib, locale set to C

And in that xterm I cannot type any accentuated chars like é á and so on. However, running with LC_ALL=nb_NO.UTF-8 xterm will make this work again. nb_NO.utf8 seems to be the default locale setting when choosing norwegian bokmål as the language for the distro. Or has this changed since I installed somehow?

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2008-10-05 06:18:34 EDT
I think this was fixed in gdm recently:

2008-10-01  Ray Strode <rstrode@redhat.com>

        * gui/simple-greeter/gdm-languages.c
        (make_codeset_canonical_for_locale),
        (gdm_normalize_language_name):
        change codeset in locale to follow canonical
        form so we end up with ".UTF-8" instead of
        ".utf8" etc.
Comment 2 Kjartan Maraas 2008-11-02 08:06:50 EST
Nah, still seeing it here with current rawhide...
Comment 3 Bug Zapper 2008-11-25 22:06:14 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Kjartan Maraas 2009-01-19 09:14:10 EST
And it's still the same when starting xterm from gnome-terminal in rawhide today.
Comment 5 Kjartan Maraas 2009-04-29 05:44:40 EDT
I'm still seeing this warning when I start xterm in today's rawhide. Is this something that's fixed if I reinstall? Leftover from my previous install which was many releases ago?
Comment 6 Ray Strode [halfline] 2009-04-29 10:09:57 EDT
Sorry for the radio silence on this bug so far...

Yea, it's probably left over cruft from rawhide.  We could in theory clean it out in GDM, but for now, you should be able to do:

rm -f ~/.dmrc
sudo gconftool-2 --recursive-unset /apps/gdm --config-source=xml:readwrite:/var/lib/gdm/.gconf

to clean things back up to defaults.

Note You need to log in before you can comment on or make changes to this bug.