Bug 462473 - Put the comment box on the top when "When viewing a bug, show comments in this order" is on Newest on top
Put the comment box on the top when "When viewing a bug, show comments in thi...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
devel
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 11:15 EDT by Matěj Cepl
Modified: 2014-10-12 18:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 02:05:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-09-16 11:15:40 EDT
Description of problem:
When going through many many bugs (like I do), I have to scroll all the time. Basic description and controlling buttons are on the top of the page, whereas comment box and the last comment (which is the most important one for me) are on the bottom.

Would it be possible to somehow concentrate all pieces of interesting information in the one place? One option would be to fix "When viewing a bug, show comments in this order" option in the preferences, so that when it is from Newest to Oldest, the comment box would be on the top as well.

Actually, even that is probably not the ideal -- I would like to have ideally various control buttons on the top (as it is now), then the comment box (with "Need additional information" box), then the last comment (which is usually the one where I reply to), then the original first comment (because it usually contains the most complete description of the problem), and the remaining comments (basically in whatever order).

However, even "the comment box following the order" would be OK for me.

What do you think?
Comment 1 David Lawrence 2008-09-16 12:40:28 EDT
I have made the needed template change to support his request. Please take a look at any test bugs you can at https://bz-web2-test.devel.redhat.com and let me know if it is satisfactory. Make sure you try each of the different comment ordering settings in userprefs.cgi to make sure it looks proper when viewing a bug report.

Dave
Comment 2 Matěj Cepl 2008-09-16 15:59:26 EDT
a) does anybody actually uses that time management box? I don't see anybody to use it, so if I was in charge (and I am not), then this box would be either hidden by default (and expandable via some AJAX magic), or move to the very bottom of the page.

b) "Newest to Oldest but keep Description on the top" in that testing bugzilla is actually pretty close to what I thought about. Or maybe just "Newest to Oldest".

Except maybe (and it looks pretty wild, when I write it) order comment box-last comment-description-other comments would be even better, but maybe it is totally silly.

Maybe this is just good.

c) attachments, external bugs, and visibility restrictions should go IMHO somewhere lower -- they are not needed that often.

Thanks a lot for the speed with which you begin to work on this.
Comment 3 David Lawrence 2008-09-18 14:39:01 EDT
Fix for this should appear in the next update today or tomorrow.

Dave
Comment 4 John Poelstra 2012-05-31 18:02:22 EDT
comment box is back at the bottom :(
Comment 5 Simon Green 2012-06-19 02:05:23 EDT
This was changed in Bugzilla 4.2, and can be set in your preference (default is still at the bottom).

(In reply to comment #2)
> a) does anybody actually uses that time management box? I don't see anybody
> to use it, so if I was in charge (and I am not), then this box would be
> either hidden by default (and expandable via some AJAX magic), or move to
> the very bottom of the page.

Yes, the Bugzilla team use it, and soon all IED developers will use it.

Note You need to log in before you can comment on or make changes to this bug.