Bug 462477 - Firewire iso transmission cannot set some fields correctly
Firewire iso transmission cannot set some fields correctly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Jay Fenlason
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 11:52 EDT by Jay Fenlason
Modified: 2013-11-03 19:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-03 19:27:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Fenlason 2008-09-16 11:52:30 EDT
Description of problem:
When using the firewire stack to send iso packets, sending packets with a sy field other than 0 or 4, or a tag field other than 0 or 2 results in sending a packet with an incorrect sy or tag field.

Version-Release number of selected component (if applicable):
The 5.2 and 5.3beta kernels.

How reproducible:
Always.

Steps to Reproduce:
1.Write a program that sends iso packets with varying sy and tag values.
2.Run it and observe the output with nosy or another firewire sniffer.
3.Observe that only the 2 bit of the tag field, and the 4 bit of the sy field ever change.
  
Actual results:
Only the 2 bit of the tag field, and the 4 bit of the sy field can be set in outgoing packets.

Expected results:
Both fields should be capable of taking all legal values.

Additional info:
This bug is in two parts: one (firewire-cdev.h) will require recompiling libraries and/or applications to fix.  Since nobody has opened a bug report on this yet, it is apparent that such applications are rare.
Comment 1 John Feeney 2013-11-03 19:27:49 EST
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore is being closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide a sufficient business justification
in order to re-open it.

Note You need to log in before you can comment on or make changes to this bug.