Bug 462491 - AttributeError: InstallInterface instance has no attribute 'getLuksPassphrase'
AttributeError: InstallInterface instance has no attribute 'getLuksPassphrase'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
high Severity medium
: beta
: ---
Assigned To: David Lehman
Brock Organ
:
: 462494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 14:11 EDT by Jeff Burke
Modified: 2010-10-23 00:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:33:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the kickstart file that was used during the install. (12.21 KB, text/plain)
2008-09-16 14:49 EDT, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2008-09-16 14:11:39 EDT
Description of problem:
* RHEL5.3-Server-20080916.nightly x86_64
* Error appears through automate RHTS testing

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20080916.nightly x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try a nfs install from pxe with a ks.cfg file, x86_64 

Actual results:
Running anaconda, the Red Hat Enterprise Linux Server system installer - please wait...
Probing for video card:   XGI Technology Inc. (eXtreme Graphics Innovation) Volari Z7
Running pre-install scripts
Traceback (most recent call first):
  File "/usr/lib/anaconda/partitioning.py", line 83, in partitioningComplete
    passphrase = anaconda.intf.getLuksPassphrase(device=dev)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 223, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/cmdline.py", line 130, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/bin/anaconda", line 1003, in ?
    anaconda.intf.run(anaconda)
AttributeError: InstallInterface instance has no attribute 'getLuksPassphrase'

install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system

Expected results:
Should install

Additional info:
Comment 1 David Lehman 2008-09-16 14:32:15 EDT
Is this text, gui, or command line mode?
Comment 2 David Lehman 2008-09-16 14:35:00 EDT
*** Bug 462494 has been marked as a duplicate of this bug. ***
Comment 3 David Lehman 2008-09-16 14:38:32 EDT
ks.cfg might end up being useful if you have it handy.
Comment 4 Jeff Burke 2008-09-16 14:49:39 EDT
Created attachment 316878 [details]
Here is the kickstart file that was used during the install.
Comment 6 Chris Lumens 2008-09-17 09:50:27 EDT
Well you've got both text and cmdline in the kickstart file, and cmdline is last so that's what wins here.  It's true that the cmdline interface has no getLuksPassphrase dialog, and it's not going to be able to grow one since the entire point of the cmdline interface is that it's not at all interactive.

The best we can do to fix the traceback is to add a dummy getLuksPassphrase method that says "Can't ask a question in cmdline mode!" and quits, similar to how messageWindow works there.  Now as for solving the problem of how to get the passphrase for existing filesystems on cmdline installs, that's a question Dave will have to answer.
Comment 7 David Lehman 2008-09-17 20:28:22 EDT
Fixed in anaconda-11.1.2.126-1.
Comment 8 RHEL Product and Program Management 2008-09-17 21:43:34 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Brock Organ 2008-09-18 22:02:02 EDT
verified fixed with RHEL5.3-Client20080918.nightly on x86_64 ...
Comment 11 errata-xmlrpc 2009-01-20 16:33:52 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html

Note You need to log in before you can comment on or make changes to this bug.