Bug 462495 - Extremely poor 3d performance on xorg-x11-drv-i810-2.4.2-8.fc10
Extremely poor 3d performance on xorg-x11-drv-i810-2.4.2-8.fc10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 14:17 EDT by Ben Gamari
Modified: 2008-09-29 04:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 01:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (30.68 KB, text/plain)
2008-09-16 14:17 EDT, Ben Gamari
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 17758 None None None Never

  None (edit)
Description Ben Gamari 2008-09-16 14:17:40 EDT
Created attachment 316874 [details]
Xorg log

Description of problem:
glxgears consistently shows 40fps without compiz. compiz produces 30 fps and down to 14 while switching workspaces with the desktop wall plugin.

Packages:
  xorg-x11-drv-i810-2.4.2-8.fc10
  xorg-x11-server-Xorg-1.5.0-6.fc10
  mesa-libGL*-7.2.0.1.fc10
  libdrm-2.4.0-0.19.fc10
  kernel-2.6.27-0.323.rc6.fc10
Comment 1 Ben Gamari 2008-09-16 14:24:19 EDT
While looking at dmesg, I just realized that the kernel had dumped 75000 messages resembling,

Sep 16 14:14:50 mercury kernel: [drm:i915_gem_execbuffer] *ERROR* Going to lose 
the write domain on obj 38 size 16777216
Sep 16 14:14:50 mercury kernel: [drm:i915_gem_execbuffer] *ERROR* Going to lose 
the write domain on obj 40 size 16777216

whenever I was running an opengl application (I know it happens when I run glxgears, I haven't had time to check compiz yet).
Comment 2 Matěj Cepl 2008-09-18 05:53:44 EDT
Throwing the bug over the fence to kernel camp.
Comment 3 Ben Gamari 2008-09-24 15:50:58 EDT
This seems to be fixed in the latest kernel build (2.6.27-0.352.rc7.git1), although performance still seems to be a little lacking (still stutters with several windows open) and the alpha blended window shadows are solid black.
Comment 4 Ben Gamari 2008-09-29 01:34:45 EDT
The gem warnings are gone with recent kernels. Closing.

Note You need to log in before you can comment on or make changes to this bug.