This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 462531 - text of highlighted button in dialog goes black
text of highlighted button in dialog goes black
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-geode (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2008-09-16 17:49 EDT by Jack Spaar
Modified: 2009-05-13 14:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 14:38:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of a zenity dialog showing blacked-out text (13.79 KB, image/png)
2008-09-16 17:50 EDT, Jack Spaar
no flags Details
screenshot of color picker appearing blacked-out (27.16 KB, image/png)
2008-09-16 19:20 EDT, Jack Spaar
no flags Details

  None (edit)
Description Jack Spaar 2008-09-16 17:49:33 EDT
Description of problem:
On XO running fedora rawhide livecd,
The highlighted button in a dialog (any app) looks black while the dialog window is in focus.

Version-Release number of selected component (if applicable):
I'm not sure which underlying component is responsible.  Here are candidates chosen from zenity's dependencies:

cairo-1.7.4-1.fc10.i386
fontconfig-2.6.0-2.fc10.i386
freetype-2.3.7-1.fc10.i386
gtk2-2.14.0-4.fc10.i386
glib2-2.18.0-1.fc10.i386
libglade2-2.6.3-1.fc10.i386
glib2-2.18.0-1.fc10.i386
libgnomecanvas-2.20.1.1-2.fc9.i386
glib2-2.18.0-1.fc10.i386
gtk2-2.14.0-4.fc10.i386
pango-1.21.6-1.fc10.i386


How reproducible: always


Steps to Reproduce:
1. Boot fedora rawhide livecd on XO per http://katzj.livejournal.com/438184.html
2. Log in to gdm and open any dialog, such as System->shutdown
3.  or run: zenity --question --text 'do you like pirate buttons?' --ok-label='Aaargh!' --cancel-label='Naargh!' 
3. 
  
Actual results:
While the dialog window is in focus, the *text* in the highlighted button appears blacked out.  Tabbing to a different button will move the effect to that button.  Focussing on a different window will remove the effect until the dialog is in focus again.  Notice that in buttons with an icon and text, the icon is not blacked out, only the text.

Expected results:
visible text on highlighted button while dialog window is active

Additional info:
Screenshot attached.

Intended to block FedoraOnXO Tracker: https://bugzilla.redhat.com/show_bug.cgi?id=FedoraOnXO
Comment 1 Jack Spaar 2008-09-16 17:50:58 EDT
Created attachment 316908 [details]
screenshot of a zenity dialog showing blacked-out text
Comment 2 Behdad Esfahbod 2008-09-16 18:11:02 EDT
That looks like the button is drawn in black when it shouldn't, not the text being of the wrong color!

At any rate, theme issue of some sort.  Not Pango definitely.
Comment 3 Jack Spaar 2008-09-16 19:20:11 EDT
Created attachment 316915 [details]
screenshot of color picker appearing blacked-out

Fair enough -- the screenshot tells the story better than I can.  If you could reassign to a more likely component that would be great -- I have no clue.  

But checking the theme I see another symptom of the same thing:

Going to System-preferences->look and feel->appearance shows "Unable to start the settings manager 'gnome-settings-daemon', and then shows a Custom theme with Nodoka controls, normal looking colors, nodoka window border, Fedora icons, Bluecurve pointer.  (This is all default from the livecd, I don't have any prefs set.)

Then when I try to change appearence pref->theme->customize->colors->input boxes->background, the color picker itself appears *all black* unless I choose an area not on the outer ring -- OR if I tab to a different input element OR if the window gets defocussed (by choosing Applications menu, e.g.).  Just like with the dialog button backgrounds.
Comment 4 Jeremy Katz 2008-09-16 21:32:57 EDT
May also be
Comment 5 Behdad Esfahbod 2008-09-16 23:01:37 EDT
I don't have any informed guess on what may be going on.  We fixed a bug in cairo that could cause this but that fix is in 1.7.4 already.
Comment 6 Jeremy Katz 2008-10-30 16:04:41 EDT
Warren points to this upstream bug --  https://bugs.freedesktop.org/show_bug.cgi?id=15700

Which also at least has a workaround
Comment 7 Bug Zapper 2008-11-25 22:06:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 gary 2009-02-28 19:20:18 EST
Just been testing build 20090227 from http://dev.laptop.org/~cjb/rawhide-xo/ on an
XO - all dialogues I tested displayed correctly, no black fill. Looking good here :-)
Comment 9 Peter Robinson 2009-04-07 12:57:43 EDT
I think this should now be fixed. Anyone still seeing this on either F10 or rawhide?
Comment 10 Peter Robinson 2009-05-13 14:38:02 EDT
Closing as this is fixed.

Note You need to log in before you can comment on or make changes to this bug.