This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 462537 - pulseaudio won't run in the login screen session
pulseaudio won't run in the login screen session
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-09-16 18:54 EDT by Matthias Clasen
Modified: 2015-01-14 18:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 14:12:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-09-16 18:54:44 EDT
...with the consequence that I can't add a 'login screen ready' sound.

Here is why:

I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root priviliges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
E: core-util.c: Home directory /var/lib/gdm not ours.

/var/lib/gdm is owned by root - should that really be a fatal error condition ?
Comment 1 Lennart Poettering 2008-09-22 18:02:55 EDT
We store auth info there, that's why I make sure that we own that dir... Dunno. Does it really make sense that that dir is owned by root?
Comment 2 Lennart Poettering 2008-09-22 18:06:14 EDT
I am reassigning this now to GDM, since I'd find it way more natural if /var/lib/gdm was owned by gdm:gdm instead of root:gdm. 

Jon, what was the reason for making it owned by root?
Comment 3 Matthias Clasen 2008-09-24 14:12:54 EDT
I've fixed this in rawhide now.
Comment 4 Christoph Wickert 2008-11-28 10:38:37 EST
This is actually a duplicate of bug #439019, which was reported 11 months ago against F8. Are there any plans to fix this in F8 and F9?
Comment 5 Christoph Wickert 2008-11-28 10:39:13 EST
(In reply to comment #4)
> This is actually a duplicate of bug #439019

Sorry, it was bug # 426632

Note You need to log in before you can comment on or make changes to this bug.