Bug 462553 - "xmlto pdf test.xml" fails: sh: /usr/share/xmlto/format/docbook/../fo/pdf: No such file or directory
"xmlto pdf test.xml" fails: sh: /usr/share/xmlto/format/docbook/../fo/pdf: No...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xmlto (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 22:10 EDT by Horst H. von Brand
Modified: 2008-09-17 04:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 04:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-09-16 22:10:53 EDT
Description of problem:
Running xmlto as per the manpage on an asciidoc generated .xml gives:

$ xmlto pdf test.xml 
Making portrait pages on letter paper (215.9mmx279.4mm)
sh: /usr/share/xmlto/format/docbook/../fo/pdf: No such file or directory

Version-Release number of selected component (if applicable):
xmlto-0.0.21-2.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Generate an .xml file (say test.xml)
2. Run "xmlto pdf test.xml"
3.
  
Actual results:
Above error message

Expected results:
An PDF file

Additional info:
Comment 1 Ondrej Vasik 2008-09-17 04:44:00 EDT
You need to install xmlto-tex subpackage. I made this split of packages due to number of complaints about passivetex/tex requirements even for text processing where is no such requirement needed. So install xmlto-tex subpackage and everything should work as expected.
Closing NOTABUG, it is not possible to generate available formats in current release of xmlto, it is planned to generate such list dynamically in one of the future xmlto releases. Sorry for troubles, split of packages was announced on fedora-devel-list, but it is easy to miss such email.

Note You need to log in before you can comment on or make changes to this bug.