Bug 462575 - named query denied syslog messages lack information
named query denied syslog messages lack information
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Tkac
: EasyFix, Regression
Depends On: 241745
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 03:41 EDT by Adam Tkac
Modified: 2013-04-30 19:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 07:21:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Adam Tkac 2008-09-17 03:44:56 EDT
As written bellow RHBA-2008-0708 caused small regression with logging:

--- Additional comment from vogel@folz.de on 2008-09-04 05:45:10 EDT ---

This patch apparently changes the logging category for this log message.

In prior versions, the "query (cache) denied" message would fall under the
"client" category, and the config entry

logging {
  category client { file "client_log"; };
};

would redirect this message away from syslog to a file.

With bind-9.2.4-30.el4, this stopped to work, and the message appears in
/var/log/messages instead.

Could you please change the patch so that it does not break the logging
configurability?
Comment 2 RHEL Product and Program Management 2008-09-17 03:45:49 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Adam Tkac 2010-02-23 07:21:50 EST
Red Hat Enterprise Linux 4.9 update will contain only important, security and performance related fixes thus this issue won't be fixed in RHEL 4.

Note that bind in Red Hat Enterprise Linux 5 has same behavior as current ("broken") Red Hat Enterprise Linux 4 bind. This change is not Red Hat specific, it has been done by upstream developers.

Note You need to log in before you can comment on or make changes to this bug.