Bug 462576 - Error while adding new Client to Spacewalk Server
Error while adding new Client to Spacewalk Server
Status: CLOSED DUPLICATE of bug 453398
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
0.1
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-09-17 04:59 EDT by Wayne Dovey
Modified: 2008-09-22 07:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-22 07:51:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Dovey 2008-09-17 04:59:02 EDT
Description of problem:

There is an error is the /var/log/up2date file when adding a new client to the spacewalk server. The client does appear on the UI but no Hosted Virtual Systems appear. After further investigation I get the following error in the /var/log/up2date file.

[Wed Sep 17 11:56:49 2008] up2date   File "/usr/sbin/rhnreg_ks", line 267, in ?
    cli.run()
   File "rhncli.py", line 65, in run
   File "/usr/sbin/rhnreg_ks", line 176, in main
    rhnreg.sendVirtInfo(systemId)
   File "rhnreg.py", line 648, in sendVirtInfo
   File "/usr/share/rhn/virtualization/support.py", line 83, in refresh
    plan.execute()
   File "/usr/share/rhn/virtualization/notification.py", line 78, in execute
    log.trace_me()
   File "up2dateLog.py", line 41, in trace_me

[Wed Sep 17 11:56:49 2008] up2date Error communicating with server. The message was:
While running 'registration.virt_notify': caught
exceptions.TypeError : Procedure() takes exactly 1 argument (2 given)

[Wed Sep 17 11:56:49 2008] up2date Error communicating with server. The message was:
While running 'registration.virt_notify': caught
exceptions.TypeError : Procedure() takes exactly 1 argument (2 given)

[Wed Sep 17 11:56:57 2008] up2date logging into up2date server


Version-Release number of selected component (if applicable):

Client versions 

rhn-setup-gnome-0.4.17-8
rhnlib-2.2.5-1
rhnsd-4.6.1-1
rhn-virtualization-host-5.2.0-5
rhn-check-0.4.17-8
yum-rhn-plugin-0.5.3-6.6
rhn-virtualization-common-5.2.0-5
rhn-client-tools-0.4.17-8
rhn-setup-0.4.17-8

Spacewalk Server versions

rhns-xmlrpc-0.1-4.el5
rhn-satellite-config-5.2.0-1.el5
rhn-cypress-0.1-4.el5
rhns-certs-tools-5.2.0-2.el5
rhns-server-0.1-4.el5
rhns-package-push-server-0.1-4.el5
rhn-pxt-0.1-4.el5
rhn-java-lib-sat-0.1-3.el5
rhnlib-2.2.5-1
rhns-config-files-common-0.1-4.el5
rhns-config-files-0.1-4.el5
rhns-xp-0.1-4.el5
rhn-satellite-schema-5.1.0-27
rhn-moon-0.1-4.el5
rhn-dobby-0.1-4.el5
rhn-java-sat-0.1-3.el5
rhn-client-tools-0.4.13-1.SEL5
rhns-0.1-4.el5
rhns-xml-export-libs-0.1-4.el5
rhns-config-files-tool-0.1-4.el5
rhn-grail-0.1-4.el5
rhn-satellite-admin-5.2.0-3.el5
rhn-java-config-sat-0.1-3.el5
rhn-oracle-jdbc-1.0-16
rhn-virtualization-host-5.2.0-5
rhns-sql-0.1-4.el5
rhns-applet-0.1-4.el5
rhn-html-0.1-4.el5
rhnpush-5.2.0-5
rhn-base-0.1-4.el5
rhns-satellite-tools-0.1-4.el5
rhn-oracle-jdbc-tomcat5-1.0-16
rhn-virtualization-common-5.2.0-5
rhns-app-0.1-4.el5
rhn-sniglets-0.1-4.el5
rhn-org-httpd-ssl-key-pair-spacewalk-lon01-01-1.0-7
xorg-x11-drv-spaceorb-1.1.0-1.1
perl-XML-NamespaceSupport-1.09-1.2.1
spacewalk-setup-0.01-3
spacewalk-0.1-7

How reproducible:


Steps to Reproduce:
1. Delete Client from server 
2. Add server with rhnreg_ks --force --serverUrl=http://spacewalkserver/XMLRPC --activationkey=1-xxxxxxxxxxxxxxxxxxxxxxxxxxx
3. check /var/log/up2date file
  
Actual results:

Client added to spacewalk UI without Hosted Virtual Systems  

Expected results:

Hosted Virtual Systems is not displayed on web UI.

Additional info:
Comment 1 Pradeep Kilambi 2008-09-22 07:51:18 EDT
this should be resolved in 0.2 spacewalk server. closing as dup of bz#453398

*** This bug has been marked as a duplicate of bug 453398 ***

Note You need to log in before you can comment on or make changes to this bug.