Bug 462606 - No keyboard in xorg-x11-server-Xorg-1.5.0-1.fc9.x86_64
No keyboard in xorg-x11-server-Xorg-1.5.0-1.fc9.x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Reopened
: 469508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 10:07 EDT by Patrick O'Callaghan
Modified: 2008-11-14 07:44 EST (History)
11 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.5.2-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-09 23:44:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from xorg-x11-server-Xorg-1.5.0-1.fc9.x86_64 (21.30 KB, text/plain)
2008-09-17 10:07 EDT, Patrick O'Callaghan
no flags Details
xorg.conf (1.05 KB, text/plain)
2008-09-17 14:27 EDT, Peter Robinson
no flags Details
Keyboard section of hal-device output (1.16 KB, text/plain)
2008-09-18 04:51 EDT, sjbertram
no flags Details
xorg.conf (2.20 KB, text/plain)
2008-09-18 04:52 EDT, sjbertram
no flags Details
X.log.0 file from failing xorg-x11-server-common-1.5.2-2.fc9.x86_64 (21.58 KB, text/plain)
2008-11-02 22:16 EST, Patrick O'Callaghan
no flags Details

  None (edit)
Description Patrick O'Callaghan 2008-09-17 10:07:13 EDT
Created attachment 316962 [details]
Xorg.0.log from xorg-x11-server-Xorg-1.5.0-1.fc9.x86_64

Description of problem:
Xorg server has no keyboard

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.0-1.fc9.x86_64

How reproducible:
Install and run the latest Xorg from updates-testing.

Steps to Reproduce:
1.Install Xorg
2.Restart X
3.
  
Actual results:
No kb except for Alt-Fn keys

Expected results:
Normally-working kb

Additional info:
Tried this under both gdm and kdm (from KDE 4.1.1). Same result. The physical kb is a standard US-layout PS2. The mouse works fine. Possibly related to evdev as this seems to have changed since the previous (working) version, xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.x86_64.

I have no xorg.conf. I include the Xorg.0.log file.
Comment 1 Peter Robinson 2008-09-17 10:57:57 EDT
I saw the same issues on my laptop keyboard with yesterday's testing updates
and had to add an input section into my xorg.conf. Same situation ALT+F1 got me
to a console but nothing else worked. Mouse worked fine.

I have (had) only a minimal xorg.conf that allocated a virt so my dual monitors worked with xrandr when I'm in the office.

The hal-device outputs the following for the keyboard.

14: udi =
'/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input4/event4' 
(string)
  info.subsystem = 'input'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port' 
(string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  info.callouts.add = { 'hal-setup-keymap' } (string list)
  info.udi =
'/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input' 
(string)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  input.originating_device =
'/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.device_file = '/dev/input/event4'  (string)
  input.keymap.data = { 'e001:fn_esc', 'e009:battery', 'e00a:screenlock',
'e033:f22' } (string list)
  input.xkb.rules = 'base'  (string)
  linux.subsystem = 'input'  (string)
  input.xkb.model = 'evdev'  (string)
  input.xkb.layout = 'us'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad',
'input.keys', 'input.keymap', 'button' } (string list)
  input.xkb.variant = ''  (string)
  info.category = 'input'  (string)
  input.x11_driver = 'evdev'  (string)
  input.device = '/dev/input/event4'  (string)
  input.product = 'AT Translated Set 2 keyboard'  (string)
Comment 2 Patrick O'Callaghan 2008-09-17 14:13:16 EDT
(In reply to comment #1)
> I saw the same issues on my laptop keyboard with yesterday's testing updates
> and had to add an input section into my xorg.conf.

I'd be interested in seeing your input section.

> Same situation ALT+F1 got me
> to a console but nothing else worked. Mouse worked fine.
> 
> I have (had) only a minimal xorg.conf that allocated a virt so my dual monitors
> worked with xrandr when I'm in the office.
> 
> The hal-device outputs the following for the keyboard.
[...]

Here's my hal-device section for what it's worth:

18: udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  input.device = '/dev/input/event3'  (string)
  info.subsystem = 'input'  (string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  input.product = 'AT Translated Set 2 keyboard'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input3/event3'  (string)
  info.category = 'input'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button' } (string list)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  input.xkb.rules = 'base'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  input.xkb.model = 'evdev'  (string)
  linux.subsystem = 'input'  (string)
  linux.device_file = '/dev/input/event3'  (string)
  input.xkb.layout = 'us'  (string)
  input.xkb.variant = ''  (string)
  input.x11_driver = 'evdev'  (string)
Comment 3 Peter Robinson 2008-09-17 14:27:57 EDT
Created attachment 316996 [details]
xorg.conf

This is my xorg.conf. It use to be that I didn't have one but to hotplug a second monitor with xrandr you need to add a virtualise option so its sort of expanded out over time.
Comment 4 Mark Wielaard 2008-09-17 18:29:35 EDT
Thanks for the hint on creating a minimal /etc/X11/xorg.conf. Now my keyboard works again under X. For some reason I didn't have any xorg.conf file before. This was fine with xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386 but apparently broke when upgrading to 1.5.0-1.fc9.i386
Comment 5 Patrick O'Callaghan 2008-09-17 21:08:35 EDT
(In reply to comment #3)
> Created an attachment (id=316996) [details]
> xorg.conf
> 
> This is my xorg.conf. It use to be that I didn't have one but to hotplug a
> second monitor with xrandr you need to add a virtualise option so its sort of
> expanded out over time.

Thanks. I was keen to try this, but when I tried to reinstall Xorg 1.5 yum couldn't find it. I wonder if it has been withdrawn from updates-testing.
Comment 6 Fedora Update System 2008-09-17 22:33:40 EDT
xorg-x11-server-1.5.0-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.5.0-2.fc9
Comment 7 sjbertram 2008-09-18 04:43:12 EDT
I've just encountered the same bug with a UK PS/2 keyboard in the i386 binaries. Reverting to xorg-x11-server-Xorg-1.4.99.905-2.20080702 and xorg-x11-server-common-1.4.99.905-2.20080702 seems to resolve the problem.

My xorg.conf doesn't have an input section, but it didn't have one before the update either and it still functioned correctly. I'll attach my xorg.conf and the important part of the hal-device output in a minute.
Comment 8 sjbertram 2008-09-18 04:51:57 EDT
Created attachment 317050 [details]
Keyboard section of hal-device output
Comment 9 sjbertram 2008-09-18 04:52:49 EDT
Created attachment 317051 [details]
xorg.conf
Comment 10 Matěj Cepl 2008-09-18 05:40:32 EDT
Patrick and sjbertram, did xorg-x11-server-1.5.0-2.fc9 fixed your problem?
Comment 11 sjbertram 2008-09-18 06:37:27 EDT
Sorry - I somehow missed comment #6 and didn't realise there was a later build. I checked the repos using Smart this morning and hadn't seen anything new.

It does seem to have fixed it, though. I can now log in using the keyboard (instead of the on-screen keyboard) and it works within Gnome as well. Given the comment on the build and my xorg.conf (which has never had an input section generated for some reason) then it makes sense.

Thanks.
Comment 12 Patrick O'Callaghan 2008-09-18 08:16:53 EDT
(In reply to comment #10)
> Patrick and sjbertram, did xorg-x11-server-1.5.0-2.fc9 fixed your problem?

I still don't see the new version in updates-testing. I'll try it when it shows up.
Comment 13 sjbertram 2008-09-18 08:33:14 EDT
Patrick, you can get it from Koji via the link in comment #6. The various versions are at http://koji.fedoraproject.org/koji/buildinfo?buildID=63479
Comment 14 Patrick O'Callaghan 2008-09-18 09:17:58 EDT
(In reply to comment #13)
> Patrick, you can get it from Koji via the link in comment #6. The various
> versions are at http://koji.fedoraproject.org/koji/buildinfo?buildID=63479

OK, did that and it seems to work. Thanks everyone :-)
Comment 15 David Rees 2008-09-18 17:23:29 EDT
xorg-x11-server-1.5.0-2.fc9 fixed the no keyboard problem for me.

I have a Dell Vostro 1000, no xorg.conf file.

Was a major PITA to get things working again on my notebook because of Bug 450748 which leaves my VTs completely garbled when switching to them after entering X.

Had to boot into single user mode and manually bring up the network to get things going, stuff that would have stumped someone not familiar with Linux.
Comment 16 Axel Thimm 2008-09-20 04:59:56 EDT
Please do not close bugs that are to be closed by bodhi. It filters them out of the default searches in bugzilla and users can't find them resulting in lengthy searches or duplicate reports.

Once bodhi moves this to testing or stable it will automagically take care of the bug's status as well.

Thanks!
Comment 17 M. A. MacLain 2008-09-20 21:45:56 EDT
Updating to  xorg-x11-server-Xorg.x86_64 and  xorg-x11-server-common_x86_64 to version 1.5.0-1.fc9  from 1.4.99.905-120080701.fc9  did not affected the keyboard but it disrupted the mouse operation making it impossible to use xorg-x11 except by means of keyboard shortcuts.  This happened  in an existing F-9 installation as well as in other two clean installs.  Exempting    xorg-x11-server-Xorg.x86_64 and  xorg-x11-server-common_x86_64 in yum update and manually installing version  1.5.0-2.fc9  solved the problem and the systems are operating satisfactorily.

Regards
Comment 18 Chris Wright 2008-09-22 16:05:03 EDT
Upgrading from xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.x86_64 to xorg-x11-server-Xorg-1.5.0-1.fc9.x86_64.rpm killed my keyboard as well (only Alt-Fn, Ctlr-Alt-Backspace, etc working):

(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
        If no devices become available, reconfigure HAL or disable AllowEmptyInput.

After updating to xorg-x11-server-Xorg-1.5.0-2.fc9.x86_64.rpm, all appears to be working properly again.  So, just a "Works For Me Too" comment.  Thanks.
Comment 19 Tom Cross 2008-09-23 12:01:38 EDT
I installed xorg-x11-server-common-1.5.0-2.fc9.i386 and it solved my USB keyboard not working problem.  However, I no longer can use both my screens.  They only work in mirror mode.  Don't know if that's related.
Comment 20 Fedora Update System 2008-09-24 20:00:37 EDT
xorg-x11-server-1.5.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Patrick O'Callaghan 2008-10-31 18:07:06 EDT
Updating from xorg-x11-server-common-1.5.0-3.fc9.x86_64 to xorg-x11-server-common-1.5.2-2.fc9.x86_64 brought the problem back (same machine, display etc. as before). Had to regress to recover.

# hal-device|grep input.x11_driver
  input.x11_driver = 'evdev'  (string)
  input.x11_driver = 'evdev'  (string)
  input.x11_driver = 'evdev'  (string)
Comment 22 Peter Hutterer 2008-11-02 19:57:05 EST
Patrick:
do you still have the log file from the busted server?
Comment 23 Patrick O'Callaghan 2008-11-02 22:16:07 EST
Created attachment 322257 [details]
X.log.0 file from failing xorg-x11-server-common-1.5.2-2.fc9.x86_64

Log file as requested
Comment 24 Fedora Update System 2008-11-03 00:51:11 EST
xorg-x11-server-1.5.2-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.5.2-3.fc9
Comment 25 Peter Hutterer 2008-11-03 01:01:42 EST
Looks like in the 1.5.2 update a hunk to a fedora-specific patch got lost. Should be fixed with 1.5.2-3 now.
Comment 26 Patrick O'Callaghan 2008-11-03 15:41:10 EST
That did the trick, thanks.
Comment 27 Peter Hutterer 2008-11-04 20:05:55 EST
*** Bug 469508 has been marked as a duplicate of this bug. ***
Comment 28 dex 2008-11-06 12:49:46 EST
keyboard back working without xorg.conf but arrow keys & others still busted returning model back to btc6301urf from evdev cures this.
i686 
xorg-x11-drv-keyboard-1.3.0-3.fc9.i386
xorg-x11-server-Xorg-1.5.2-3.fc9.i386
xorg-x11-drv-evdev-2.0.7-1.fc9.i386
xorg-x11-drv-ati-6.8.0-19.fc9.i386
kernel-2.6.27.4-19.fc9.i686
Comment 29 Peter Hutterer 2008-11-09 23:44:43 EST
F9 doesn't use the evdev driver for keyboards, so model evdev is just a misconfiguration.
Comment 30 Fedora Update System 2008-11-14 07:44:52 EST
xorg-x11-server-1.5.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.