Bug 462611 - scidavis should filter out Provides: libfitRational*
scidavis should filter out Provides: libfitRational*
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scidavis (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Tanguy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 10:41 EDT by Matt Domsch
Modified: 2008-09-17 11:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 10:57:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-09-17 10:41:41 EDT
+++ This bug was initially created as a clone of Bug #434100 +++

--- Additional comment from matt_domsch@dell.com on 2008-09-17 09:14:03 EDT ---

scidavis had a dependency on libfitRational[01].so.1, which is provided by qtiplot.  Is this an unneeded dependency?

qtiplot-0.9-8.fc9.x86_64 [cmd line]
 \_  scidavis-0.1.3-2.fc10.x86_64 [2: libfitRational0.so.1()(64bit), libfitRational1.so.1()(64bit)]

--- Additional comment from eric.tanguy@univ-nantes.fr on 2008-09-17 09:22:05 EDT ---

rpm -ql scidavis

...
/usr/lib/scidavis/plugins/libfitRational0.so
/usr/lib/scidavis/plugins/libfitRational0.so.1
/usr/lib/scidavis/plugins/libfitRational0.so.1.0
/usr/lib/scidavis/plugins/libfitRational0.so.1.0.0
/usr/lib/scidavis/plugins/libfitRational1.so
/usr/lib/scidavis/plugins/libfitRational1.so.1
/usr/lib/scidavis/plugins/libfitRational1.so.1.0
/usr/lib/scidavis/plugins/libfitRational1.so.1.0.0
...

--- Additional comment from matt_domsch@dell.com on 2008-09-17 10:38:35 EDT ---

ah ha.  Turns out they're identical libraries because they're identical plugins, one for each package.  Those should not be included as Provides (which are handed by the automatic provides detection) in either package.  Turns out yum gets it right, and installing one doesn't pull in the other, but they're useless (and potentially harmful) Provides anyhow.

http://fedoraproject.org/wiki/Packaging/Perl#Filtering_Requires:_and_Provides
describes how to filter these out for a perl package.  It's the same idea for C, except you'll be filtering libfitRational* out.

With help from ajax:

%{expand:%%define prev__find_provides %{__find_provides}}
%define __find_provides %{SOURCE11} %{prev__find_provides}

where SOURCE11 is a shell script that does "$@" | awk 'filter out the badness'
Comment 1 Eric Tanguy 2008-09-17 10:57:49 EDT
qtiplot is still not released (i can't find it in any fedora repo). scidavis is released for 5 months. So i think qtiplopt have to care about this before release
Comment 2 Matt Domsch 2008-09-17 11:23:44 EDT
qtiplot was released as part of Fedora 9.  It's in the "Everything" directory of Fedora 9, and is also built in rawhide.
Comment 3 Eric Tanguy 2008-09-17 11:50:15 EDT
The same for scidavis but since fedora 8.

Note You need to log in before you can comment on or make changes to this bug.